This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 9620 - invalid error claiming blank document
Summary: invalid error claiming blank document
Alias: None
Product: Validator
Classification: Unclassified
Component: check (show other bugs)
Version: 0.6.0
Hardware: All All
: P2 normal
Target Milestone: 1.0
Deadline: 2018-01-14
Assignee: This bug has no owner yet - up for the taking
QA Contact: Web Media Text Tracks CG
Depends on:
Reported: 2010-04-29 16:32 UTC by rob
Modified: 2018-10-15 08:16 UTC (History)
9 users (show)

See Also:


Description rob 2010-04-29 16:32:15 UTC
I enter HTML into the validator under teh direct input tab, and I get the following error:

end of document in prolog
This error may appear when the validator receives an empty document. Please make sure that the document you are uploading is not empty, and report any discrepancy.

HTML is listed below.

This is similar to closed bug 6151.


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "">
<html xmlns="">

<head profile="">
	<title>Rob's Ramblings</title>
	<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
	<meta name="generator" content="Mango 1.4.3" />
	<meta name="description" content="" />
	<meta name="robots" content="index, follow" />

	<link rel="alternate" type="application/atom+xml" title="Atom" href="" />
	<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="" />	
	<link rel="EditURI" type="application/rsd+xml" title="RSD" href="" />
	<link rel="stylesheet" type="text/css" href="/blog/skins/glossyblue/assets/styles/main.css"  media="all" />
	<link rel="stylesheet" type="text/css" href="/blog/skins/glossyblue/assets/styles/print.css" media="print" />
	<link rel="stylesheet" type="text/css" href="/blog/skins/glossyblue/assets/styles/custom.css"  media="all" />
	<link rel="stylesheet" href="/blog/assets/plugins/colorcoding/style.css" type="text/css" />
<div id="page">
  <div id="header">

    <div id="headerimg">
	  <h1><a href="/blog/">Rob's Ramblings</a></h1>
	  <div class="description"></div>

	<ul id="nav">
	  <li class="page_item"><a href="/blog/" title="Home">Home</a></li>
		<li class="page_item"><a href="/blog/page.cfm/about-me" title="About Me">About Me</a></li>

  <!--/header -->
  <div id="content">    
			<div class="post" id="post-AB979F80-0E51-DAEE-DA2E2E82B089707D">
	  			<div class="post-date"><span class="post-month">Mar</span> <span class="post-day">29</span></div>
				  <div class="post-title">
				  <h2><a href="/blog/post.cfm/cfbuilder-standalone-and-cvs" rel="bookmark" title="Permanent Link to CFBuilder standalone and CVS">CFBuilder standalone and CVS</a></h2>

					<span class="post-cat"><a href="/blog/archives.cfm/category/coldfusion" title="View all posts in  ColdFusion" rel="category tag">ColdFusion</a> </span> 
					<span class="post-comments"><a href="/blog/post.cfm/cfbuilder-standalone-and-cvs#comments" title="Comment on CFBuilder standalone and CVS">5 Comments &#187;</a></span>			
				  <div class="entry">
					<p>Adobe released CFBuilder to the paying public, as we all know. And it looks like they fixed quite a few things from the last beta. But they also broke one thing, and it's a real bother.</p>
<p>As of this official release, you no longer can manually install CVS into a standalone installation of CFBuilder. In teh betas, you could do this via the Eclipse 3.4 update sites (noted in this <a href="" target="_blank">blog post</a>). Now, it generates an incompatability error.</p>
<p><strong>UPDATE</strong>: The fix to this was to use the correct update site for Eclipse 3.5. The site to use is I had been using and that was incorrect. Thanks to Nathan Mische for pointing this out to me!</p>

<h6><em>Comments are moderated for this blog solely for spam-prevention purposes.</em><br /></h6> 
			</div><!--/post -->		
			<div class="post" id="post-DC707DAE-A664-BD34-80342C19EBECB5DE">
	  			<div class="post-date"><span class="post-month">Feb</span> <span class="post-day">18</span></div>
				  <div class="post-title">
				  <h2><a href="/blog/post.cfm/cfbuilder-has-become-unusable-for-me" rel="bookmark" title="Permanent Link to CFBuilder has become unusable for me">CFBuilder has become unusable for me</a></h2>
					<span class="post-cat"><a href="/blog/archives.cfm/category/coldfusion" title="View all posts in  ColdFusion" rel="category tag">ColdFusion</a> </span> 
					<span class="post-comments"><a href="/blog/post.cfm/cfbuilder-has-become-unusable-for-me#comments" title="Comment on CFBuilder has become unusable for me">7 Comments &#187;</a></span>			

				  <div class="entry">
					<p>This post is one of those where I am hoping somebody can provide me with some assistance.</p>
<p>I have been using CFBuilder on Snow Leopard for months now. I love it. I especially love the server consoles, the tailview, and the RDS services. The only thing I have not loved about it are the occasional crashes, but I expect it from beta software. </p>
<p>In the last week however, they have become more than occasional. They have become regular. CFBuilder constantly is hanging, eating up all of my CPU, and giving me constant Java Heap Space errors. Ususally it's trying to build project settings or index projects, and I can let them go on for literally hours at a time and nothing will happen. I've had to Force Quit CFBuilder numerous times now.</p>
<p>I went so far as to uninstall it and do a fresh install, no avail.</p>
<p>If anyone has some things that could help me, I would be appreciative. I'm back using CFEclipse, and it's just not the same for me.</p>
<h6><em>Please note that all comments are moderated for spam-prevention purposes only.</em></h6> 
			</div><!--/post -->		
			<div class="post" id="post-DA8B51DE-FA43-A4EA-60D951162FE72D5E">

	  			<div class="post-date"><span class="post-month">Feb</span> <span class="post-day">8</span></div>
				  <div class="post-title">
				  <h2><a href="/blog/post.cfm/what-i-learned-today-i-blame-ben-nadel-for-this-post" rel="bookmark" title="Permanent Link to What I Learned Today - I blame Ben Nadel for this post...">What I Learned Today - I blame Ben Nadel for this post...</a></h2>
					<span class="post-cat"><a href="/blog/archives.cfm/category/what-i-learned-today" title="View all posts in  What I Learned Today" rel="category tag">What I Learned Today</a> , <a href="/blog/archives.cfm/category/coldfusion" title="View all posts in  ColdFusion" rel="category tag">ColdFusion</a> </span> 
					<span class="post-comments"><a href="/blog/post.cfm/what-i-learned-today-i-blame-ben-nadel-for-this-post#comments" title="Comment on What I Learned Today - I blame Ben Nadel for this post...">6 Comments &#187;</a></span>			

				  <div class="entry">
					<p>Okay, the title is meant to be facetious, and attention grabbing. Just so we're all on the same page. But it's not untrue.</p>
<p>Through <a href="" target="_blank">Ben Nadel's fantastic blog</a>, I learned the practice of creating and scoping a LOCAL struct in a CF function (CFMX7 and CF8), and assigning any other local variable created in the function into that struct. That way I did not need to manage multiple variables, trying to make sure they were all locally scoped. It seemed more efficient.</p>
<p>Well, with the migration of my VPS to CF9 (and the impending upgrade of my work's servers to CF9), I found blog posts talking about how others that had used this practice were finding oddities with their code upon upgrading. It seems that this practice was somehow colliding with the new protected "local" scope within functions in CF9. The new scope allows coders to do exactly what I was doing, only without having to scope that local struct first.</p>
<p>In trying to figure out what changes I needed to make, I went asking around trying to find out if this meant that we no longer had to scope local variables anymore inside of functions, if unscoped variables would automatically get put in the new local scope. To hear and read the documentation, you certainly could come to that conclusion.</p>
<p>Thanks to Ray Camden, I have been straightened out. It turns out this is not the case, and I am not the first to ask him this. He was kind enough to make this topic <a href="" target="_blank">an entry in his just as fantastic blog</a>.</p>

<p>Bottom line, you don't have to scope things put in the local scope, but you must explicity call the variable in the local scope (local.myVariable). And all other variables must still be scoped for protection.</p> 
			</div><!--/post -->		
			<div class="post" id="post-CC8778FA-0718-EBC3-681E8A22A75A91BB">
	  			<div class="post-date"><span class="post-month">Feb</span> <span class="post-day">8</span></div>
				  <div class="post-title">
				  <h2><a href="/blog/post.cfm/google-chrome-and-missing-form-fields" rel="bookmark" title="Permanent Link to Google Chrome and missing form fields">Google Chrome and missing form fields</a></h2>
					<span class="post-cat"><a href="/blog/archives.cfm/category/chrome" title="View all posts in  Chrome" rel="category tag">Chrome</a> , <a href="/blog/archives.cfm/category/coldfusion" title="View all posts in  ColdFusion" rel="category tag">ColdFusion</a> , <a href="/blog/archives.cfm/category/web-development" title="View all posts in  Web Development" rel="category tag">Web Development</a> </span> 
					<span class="post-comments"><a href="/blog/post.cfm/google-chrome-and-missing-form-fields#comments" title="Comment on Google Chrome and missing form fields">8 Comments &#187;</a></span>			

				  <div class="entry">
					<p>On a legacy application that I maintain, I have seen a rash of errors recently that are new. They are all in regards to form fields missing on a form action page. The things that make this one different is that:</p>
<li>The fields in question are empty text fields, not unchecked radio buttons or checkboxes.</li>
<li>The browser type of all these errors in Google Chrome</li>
<p>Now, while the fix is the same for all of these issues (CFPARAM the form fields), I was wondering if others have been seeing this with Chrome at all, and if there's any insights as to why Chrome seems to not want to pass along empty text fields, like every other browser out there does. I have not played with Chrome at all, and our applications do not officially support that browser at this time, so I can't spend much time at all investigating these errors in light of that. So I am hoping that some of y'all might have some information you would be willing to share?</p> 
			</div><!--/post -->		
			<div class="post" id="post-1CFB253E-E901-EC4B-D3665C69D3C8DF91">

	  			<div class="post-date"><span class="post-month">Feb</span> <span class="post-day">4</span></div>
				  <div class="post-title">
				  <h2><a href="/blog/post.cfm/new-cfml-engine-and-an-unplanned-new-look" rel="bookmark" title="Permanent Link to New CFML Engine, and An Unplanned New Look">New CFML Engine, and An Unplanned New Look</a></h2>
					<span class="post-cat"><a href="/blog/archives.cfm/category/miscellaneous" title="View all posts in  Miscellaneous" rel="category tag">Miscellaneous</a> , <a href="/blog/archives.cfm/category/viviotech" title="View all posts in  Viviotech" rel="category tag">Viviotech</a> </span> 
					<span class="post-comments"><a href="/blog/post.cfm/new-cfml-engine-and-an-unplanned-new-look#comments" title="Comment on New CFML Engine, and An Unplanned New Look">2 Comments &#187;</a></span>			

				  <div class="entry">
					<p>So my blog has gotten a little dusty, this is going to happen from time to time. This is beginning the my busiest time of the year annually at work, and I also had some elective surgeries done in January to repair some longstanding issues finally fixed. While being doped up on Vicodin would make for some interesting blogging, I felt discretion was the bestter path to take...</p>
<p>But today Viviotech gave me a late Christmas present and upgraded my VPS to ColdFusion 9 (woo hoo!) and my old Mango Blog bit the big one because of it (boo!). I'm not sure why this happened, I had not altered the code in any meaningful way that shold have caused it to bomb. And to be frank, Mango Blog's error handling is... less than informative - even with Coldfire running I couldn't find much in the way of meaningful error messages to work on.</p>
<p>So, I backed up the database (God love MySQL for making this task a cinch compared to MSSQL), and nuked my old blog code and installed the latest (v1.4.3). Then after a little trial and error with the database, I got it all back running. In doing so, I had lost the mods I had made to the old design, so I am using this one as a starting point. I like the layout, but not a big fan of the blue, so on my to-do list now is a revaming of the color scheme.</p>
<p>Now that I have CF9 on here, I'm looking forward to some big things in 2010. It will get even better when my day job finally gets out of the Stone Age and gets up up from CFMX7 to CF9 in a few months! It feels like being caged when there's so much that you either cannot do, or have to jump through so many hoops that it's more cost-effective to wait for the CF9 cavalry to arrive.</p> 
			</div><!--/post -->		
<div class="navigation">
	<span class="previous-entries"><a href="/blog/archives.cfm/page/1">Previous Entries</a></span>

	<span class="next-entries"></span>

  </div><!--/content -->
<div id="sidebar">
	<form name="searchForm" id="searchform" method="get" action="/blog/archives.cfm/search/">
		<div><input type="text" value="" name="term" id="s" /><input type="submit" id="searchsubmit" value="Search" /></div>

				<h2 class="sidebartitle">Categories</h2>
		<ul class="list-cat">
		<li><a href="/blog/archives.cfm/category/bowling" title="Bowling">Bowling</a> (1)</li> 
		<li><a href="/blog/archives.cfm/category/chrome" title="Chrome">Chrome</a> (1)</li> 
		<li><a href="/blog/archives.cfm/category/coldfusion" title="ColdFusion">ColdFusion</a> (12)</li> 
		<li><a href="/blog/archives.cfm/category/family" title="Family">Family</a> (1)</li> 
		<li><a href="/blog/archives.cfm/category/flex" title="Flex">Flex</a> (2)</li> 
		<li><a href="/blog/archives.cfm/category/iphone" title="iPhone">iPhone</a> (3)</li> 
		<li><a href="/blog/archives.cfm/category/miscellaneous" title="Miscellaneous">Miscellaneous</a> (1)</li> 
		<li><a href="/blog/archives.cfm/category/os-x" title="OS X">OS X</a> (1)</li> 
		<li><a href="/blog/archives.cfm/category/php" title="PHP">PHP</a> (2)</li> 
		<li><a href="/blog/archives.cfm/category/poker" title="Poker">Poker</a> (1)</li> 
		<li><a href="/blog/archives.cfm/category/railo" title="Railo">Railo</a> (1)</li> 
		<li><a href="/blog/archives.cfm/category/ssl" title="SSL">SSL</a> (1)</li> 
		<li><a href="/blog/archives.cfm/category/viviotech" title="Viviotech">Viviotech</a> (2)</li> 
		<li><a href="/blog/archives.cfm/category/web-development" title="Web Development">Web Development</a> (8)</li> 
		<li><a href="/blog/archives.cfm/category/what-i-learned-today" title="What I Learned Today">What I Learned Today</a> (4)</li> 

				<h2 class="sidebartitle">Archives</h2>
		<ul class="list-archives">
        	<li><a href='/blog/archives.cfm/date/2010/3' title='March 2010'>March 2010</a></li>

        	<li><a href='/blog/archives.cfm/date/2010/2' title='February 2010'>February 2010</a></li>

        	<li><a href='/blog/archives.cfm/date/2009/12' title='December 2009'>December 2009</a></li>

        	<li><a href='/blog/archives.cfm/date/2009/11' title='November 2009'>November 2009</a></li>

        	<li><a href='/blog/archives.cfm/date/2009/10' title='October 2009'>October 2009</a></li>

        	<li><a href='/blog/archives.cfm/date/2009/9' title='September 2009'>September 2009</a></li>


			<h2 class="sidebartitle">Favorite Links</h2>
			<ul class="list-blogroll"> 
			<li><a href="">Rob's Facebook Page</a></li>
			<li><a href="">Rob's YouTube Channel</a></li> 

			<h2 class="sidebartitle">Hosted Web Sites</h2>
			<ul class="list-blogroll"> 
			<li><a href="">Virginia Black Sox</a></li>
			<li><a href="">Betty Barthle, Long and Foster Realtors</a></li>
			<li><a href="">Brian and Jamie's Wedding Web Site</a></li> 

				<h2 class="sidebartitle">Tag Cloud</h2>
	<style type="text/css">
		.smallestTag { font-size: xx-small; }
		.smallTag { font-size: small; }
		.mediumTag { font-size: medium; }
		.largeTag { font-size: large; }
		.largestTag { font-size: xx-large; }
  	<a href="/blog/archives.cfm/category/coldfusion"><span class="largestTag">coldfusion</span></a> <a href="/blog/archives.cfm/category/web-development"><span class="largeTag">web development</span></a> <a href="/blog/archives.cfm/category/what-i-learned-today"><span class="largeTag">what i learned today</span></a> <a href="/blog/archives.cfm/category/iphone"><span class="largeTag">iphone</span></a> <a href="/blog/archives.cfm/category/viviotech"><span class="largeTag">viviotech</span></a> <a href="/blog/archives.cfm/category/php"><span class="largeTag">php</span></a> <a href="/blog/archives.cfm/category/flex"><span class="largeTag">flex</span></a> <a href="/blog/archives.cfm/category/ssl"><span class="smallestTag">ssl</span></a> <a href="/blog/archives.cfm/category/railo"><span class="smallestTag">railo</span></a> <a href="/blog/archives.cfm/category/poker"><span class="smallestTag">poker</span></a> <a href="/blog/archives.cfm/category/os-x"><span class="smallestTag">os x</span></a> <a href="/blog/archives.cfm/category/miscellaneous"><span class="smallestTag">miscellaneous</span></a> <a href="/blog/archives.cfm/category/family"><span class="smallestTag">family</span></a> <a href="/blog/archives.cfm/category/chrome"><span class="smallestTag">chrome</span></a> <a href="/blog/archives.cfm/category/bowling"><span class="smallestTag">bowling</span></a> 

<!--/sidebar -->
  <div id="footer">
  <!--recent comments start -->
  <div class="footer-recent-posts">
    <h4>Recent Posts</h4>
		<li><strong><a href="/blog/post.cfm/cfbuilder-standalone-and-cvs" rel="bookmark" title="Permanent link to CFBuilder standalone and CVS">CFBuilder standalone and CVS</a></strong><br />

		<li><strong><a href="/blog/post.cfm/cfbuilder-has-become-unusable-for-me" rel="bookmark" title="Permanent link to CFBuilder has become unusable for me">CFBuilder has become unusable for me</a></strong><br />
		<li><strong><a href="/blog/post.cfm/what-i-learned-today-i-blame-ben-nadel-for-this-post" rel="bookmark" title="Permanent link to What I Learned Today - I blame Ben Nadel for this post...">What I Learned Today - I blame Ben Nadel for this post...</a></strong><br />

		<li><strong><a href="/blog/post.cfm/google-chrome-and-missing-form-fields" rel="bookmark" title="Permanent link to Google Chrome and missing form fields">Google Chrome and missing form fields</a></strong><br />
		<li><strong><a href="/blog/post.cfm/new-cfml-engine-and-an-unplanned-new-look" rel="bookmark" title="Permanent link to New CFML Engine, and An Unplanned New Look">New CFML Engine, and An Unplanned New Look</a></strong><br />

  <!--recent comments start -->

  <!--recent comments start -->
  <div class="footer-recent-comments">
  <h4>Recent Comments</h4>
	<li><strong><a href="/blog/post.cfm/cfbuilder-standalone-and-cvs#comment-C3DD985A-D8E3-718F-8A43FD2820E18888" title="on ">Rob Barthle</a></strong>: Nathan,That site was the exact answer I needed! I am going to update my blog...</li>

	<li><strong><a href="/blog/post.cfm/cfbuilder-standalone-and-cvs#comment-B4D9887F-A9F1-F93F-D0328F151890BC59" title="on ">Rob Barthle</a></strong>: That is a different update site than what I was using. I was using a 3.5 update...</li>
	<li><strong><a href="/blog/post.cfm/cfbuilder-standalone-and-cvs#comment-B39C020D-0139-F1B2-A41FB386D28B2157" title="on ">Nathan Mische</a></strong>: The final CF Builder is based on eclipse 3.5, not 3.4. If you try using a 3.5...</li>
	<li><strong><a href="/blog/post.cfm/cfbuilder-standalone-and-cvs#comment-B082CF59-E4D7-695D-B1816D335D3FF2D8" title="on ">Rob Barthle</a></strong>: The only thing I can offer so far is that I'm seeing some basic things not...</li>
  <!--recent comments end -->
	<!--about text start -->

	<div class="footer-about">
	<!--about text end -->
  <hr class="clear" />
  </div><!--/footer -->
</div><!--/page -->

<!--credits start -->
<div id="credits">
<div class="alignleft">Powered by <a href="" title="Mango Blog - A ColdFusion blog engine">Mango Blog</a>. Design and <a href="">Icons</a> by <a href="">N.Design Studio</a>


<div class="alignright"><a href="" class="rss">RSS Feeds</a></div>
<!--credits end -->

Comment 1 David E. Ross 2010-04-29 18:28:32 UTC
I see this problem on a PC with Windows XP.  

The problem exists not only for Direct Input but also for File Upload and Validate by URI.  

Try validating <>, which I believe successfully validated not long ago.  Try validating <>.
Comment 2 leighinternet 2010-04-29 20:06:36 UTC
I spent a while before I realised there was genuinely a problem.  However, I am finding that, although the validator does not seem to be working on Windows, it's working at the moment in Safari 4.0.5 on the Mac (Leopard OS 10.5.8).

So, to summarise, sites that previously validated (just yesterday at 9 am), no longer validate - Line 1 Column 1 - on Firefox on Windows 7 64 bit and Internet Explorer 32 bit on Windows 7 64 bit on URI validation - not tried the others.

However, if I try to validate the same pages on Safari as detailed above, they validate fine.  Hope that information is useful in some way.
Comment 3 leighinternet 2010-04-29 20:10:16 UTC
Sorry, have to now report that it is now NOT working in Safari either!!!  Just stopped!
Comment 4 David E. Ross 2010-04-29 21:24:26 UTC
This applies to both PC and Mac platforms and to both Windows and MacOS operating systems.  Please leave the Platform and OS both as "All", which is the way I am again setting them.
Comment 5 Marcello Romani 2010-04-29 21:44:14 UTC
Hi, 2010-04-29 here, and the bug makes it impossible to validate any documents, either by url, file upload or direct input.

OS is Ubuntu 9.10 fully updated as of today.
Browser tested:

FF 3.5.9 with Ubuntu modifications 1.0
Chrome 5.0.342.9 beta
Internet Explorer 7 on Win XP SP3 (on VirtualBox).
Comment 6 txitguy 2010-05-27 15:30:34 UTC
I got this same error for an uploaded XHTML document.  It doesn't look like it's even parsing the first line correctly, because the parser identified the document as "HTML 4.01 Transitional".

The first two lines, however, clearly identify it as XHTML 1.0 Strict:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "">
<html lang="en" xml:lang="en" xmlns="">
Comment 7 Larry 2010-06-03 04:37:42 UTC
I am having the same trouble.

When I first boot, I can validate two or three times, and then I get the empty document problem. Occasionally, if I come back after a couple of hours, it lets me validate two or three documents again.

It is happening both at work and at home, so it is not any of the computers I am using. The files are definitely not empty. When it does work, the the files that validated before will validate perfectly.

The url method works, but it takes 10 to 15 minutes to upload the file to my website for a check.

This is eating into my work time, as I am expected to produce working xhtml files.

It's not on my end, it is on yours. Fix it.
Comment 8 Larry 2010-06-08 13:18:26 UTC
It's also happening with the file upload. It seems the server thinks it has the file, but it does not.
Comment 9 David E. Ross 2015-08-23 16:59:12 UTC
I have not seen this problem in well over a year, perhaps several years.  As I am neither the original reporter nor a member of the W3C staff, I will not presume to close this; but I think it should now be Resolved as WorksForMe.
Comment 10 Silvia Pfeiffer 2018-01-21 18:58:15 UTC
Comment 11 Silvia Pfeiffer 2018-01-21 19:01:10 UTC
oops, sorry