Bug 9215 - Provide a Webcam example that is in accord with WCAG 2 or Defer to "HTML5: Techniques for providing useful text alternatives"
Provide a Webcam example that is in accord with WCAG 2 or Defer to "HTML5: Te...
Status: CLOSED FIXED
Product: HTML WG
Classification: Unclassified
Component: HTML5 spec
unspecified
PC All
: P1 normal
: ---
Assigned To: steve faulkner
HTML WG Bugzilla archive list
http://www.w3.org/TR/2011/WD-html5-20...
: a11y, a11ytf, a11y_text-alt, CR
Depends on: 8171 9174
Blocks: 8716
  Show dependency treegraph
 
Reported: 2010-03-08 16:41 UTC by Laura Carlson
Modified: 2013-07-16 01:42 UTC (History)
13 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laura Carlson 2010-03-08 16:41:41 UTC
SPEC SECTION: 
Images whose contents are not known [1] 

The "Images whose contents are not known" section of the HTML5 spec contains the following regarding Webcams. 

<blockquote cite="http://dev.w3.org/html5/spec/text-level-semantics.html#unknown-images">
In some unfortunate cases, there might be no alternative text available at all, either because the image is obtained in some automated fashion without any associated alternative text (e.g. a Webcam), or because the page is being generated by a script using user-provided images where the user did not provide suitable or usable alternative text (e.g. photograph sharing sites), or because the author does not himself know what the images represent (e.g. a blind photographer sharing an image on his blog).

In such cases, the alt attribute's value may be omitted, but one of the
following conditions must be met as well:

* The title attribute is present and has a non-empty value.
* The img element is in a figure element that contains a figcaption element
that contains content other than inter-element whitespace.
* The img element is part of the only paragraph directly in its section, and is
the only img element without an alt attribute in its section, and its section
has an associated heading."
</blockquote>


BUG DESCRIPTION:

There would always be something a person could provide for a Webcam text alternative.

Please provide an example that is in line with WCAG 2 or defer to "HTML5: Techniques for providing useful text alternatives": http://dev.w3.org/html5/alt-techniques/ as it is anticipated that a Webcam example will be added there. http://www.w3.org/Bugs/Public/show_bug.cgi?id=9174 

REFERENCES:

http://dev.w3.org/html5/spec/text-level-semantics.html#unknown-images [1]


HTML5 ISSUE AND CHANGE PROPOSAL:

This is associated with HTML TRACKER ISSUE-31 
http://www.w3.org/html/wg/tracker/issues/31

Change Proposal: Replace img Guidance for Conformance Checkers:
http://www.w3.org/html/wg/wiki/ChangeProposals/ImgElement20090126
Comment 1 Maciej Stachowiak 2010-03-23 06:18:42 UTC
Requesting expedited processing on behalf of the HTML WG.
Comment 2 Ian 'Hixie' Hickson 2010-03-23 08:56:36 UTC
I don't understand. How could alternative text (as opposed to caption text, which HTML5 currently requires be provided in the absence of alternative text for this exact case) be provided for an image whose contents are known to nobody at all?

Could you provide an example of what the alt="" text for the webcams on one of the following could be? A link to where WCAG2 says how to handle these would be good too.

   http://www.hb9bza.net/netcam/
   http://www.goldengatebridge.org/
   http://observatories.hodar.com/webcams.html

I'm eager to make the spec provide the best advice possible for authors, but I really don't see what we can say about webcams beyond what we already say.
Comment 3 steve faulkner 2010-03-23 17:24:22 UTC
(In reply to comment #2)
> I don't understand. How could alternative text (as opposed to caption text,
> which HTML5 currently requires be provided in the absence of alternative text
> for this exact case) be provided for an image whose contents are known to
> nobody at all?
> Could you provide an example of what the alt="" text for the webcams on one of
> the following could be? A link to where WCAG2 says how to handle these would be
> good too.
>    http://www.hb9bza.net/netcam/
>    http://www.goldengatebridge.org/
>    http://observatories.hodar.com/webcams.html
> I'm eager to make the spec provide the best advice possible for authors, but I
> really don't see what we can say about webcams beyond what we already say.

In the case of  http://www.hb9bza.net/netcam/ the image contains text (blue strip at top of image) information that is not provided elsewhere on the page, so the alt should at least include that text. same goes for example 2 http://www.goldengatebridge.org/

on the initial page of http://observatories.hodar.com/webcams.html all of the webcam images are the sole content of links, so the image alt should be describe the link target. same goes if you follow a link (e.g. http://observatories.hodar.com/sunspot/webcams.html) the images on this pages are also links and also contain date text so the text should be in the alt text.

do you have any further web cam examples that you would like text alternative advice on?
Comment 4 Ian 'Hixie' Hickson 2010-03-23 22:53:44 UTC
So it is your advice that the textual content of the image on this page:

   http://www.hb9bza.net/netcam/

...is sufficient to act as a textual replacement for the image for people who cannot see the image?
Comment 5 steve faulkner 2010-03-23 23:04:08 UTC
(In reply to comment #4)
> So it is your advice that the textual content of the image on this page:
>    http://www.hb9bza.net/netcam/
> ...is sufficient to act as a textual replacement for the image for people who
> cannot see the image?

the title above the image is "Picture and weather data from GENEVA - SWITZERLAND" 
the "weather data" is included in the image as text. At a minimum this information should be included in the text alternative.

Is it your advice that the image should not have an alt attribute with the informational text contained within the image?
Comment 6 Ian 'Hixie' Hickson 2010-03-23 23:10:39 UTC
I don't have any advice, I'm trying to work out what the spec should say.

Is the text you quoted sufficient? Or should we instead advise authors to provide this text outside the image as well, or instead? How would you write the entire alt="" text for that page's webcam image?

Are you suggesting it should just say this?:

   <img src="..." alt="Picture and weather data from GENEVA - SWITZERLAND">

I'm not trying to "trap" you or some such. I'm trying to work out what I should put in the spec, e.g. as an example, or for advice.
Comment 7 steve faulkner 2010-03-23 23:20:26 UTC
(In reply to comment #6)
> I don't have any advice, I'm trying to work out what the spec should say.
> Is the text you quoted sufficient? Or should we instead advise authors to
> provide this text outside the image as well, or instead? How would you write
> the entire alt="" text for that page's webcam image?
> Are you suggesting it should just say this?:
>    <img src="..." alt="Picture and weather data from GENEVA - SWITZERLAND">
> I'm not trying to "trap" you or some such. I'm trying to work out what I should
> put in the spec, e.g. as an example, or for advice.

I don't have the bandwidth for this back and for at the moment, as you  know I am working on  a text alternative doc: http://dev.w3.org/html5/alt-techniques/
I have a request to add webcam examples, so will ping you when thats done, you may find them useful for your text alternative stuff.
Comment 8 Maciej Stachowiak 2010-03-24 00:40:15 UTC
The image currently says:

"GENEVA/SWITZERLAND  24-Mar 2010 01:36:38 local  www.hb9bza.net  12.9ºC/55.2ºF 56% RH 1014.8 hPA    (exp: 15000)".

It seems like this might be adequate alt text for the image, perhaps excluding the domain name. It seems like for the page to be properly accessible, that content needs to be made available as text in some form.
Comment 9 Ian 'Hixie' Hickson 2010-03-24 05:34:56 UTC
I think it's reasonable to suggest that any text in the image should be provided in textual form, but I would be shocked to see any accessibility expert suggest that was an adequate replacement for the image. Laura, could you comment on this? What is your opinion on the matter? Your replies to comment 2 and comment 4 would be most appreciated.
Comment 10 steve faulkner 2010-03-24 05:46:19 UTC
(In reply to comment #9)
> I think it's reasonable to suggest that any text in the image should be
> provided in textual form, but I would be shocked to see any accessibility
> expert suggest that was an adequate replacement for the image. 

Not considering myself an expert, I consider maciejs suggestion to be reasonable given the context, perhaps with the addition of text such as 'aerial view of geneva' or some such descriptive text.
Comment 11 Laura Carlson 2010-03-27 09:01:29 UTC
(In reply to comment #9)
> I think it's reasonable to suggest that any text in the image should be
> provided in textual form, but I would be shocked to see any accessibility
> expert suggest that was an adequate replacement for the image. Laura, could you
> comment on this? What is your opinion on the matter? Your replies to comment 2
> and comment 4 would be most appreciated.

http://www.w3.org/Bugs/Public/show_bug.cgi?id=9215#c9

Hi Ian,

From WCAG:

"1.1.1 Non-text Content: All non-text content that is presented to the user has a text alternative that serves the equivalent purpose, except for the situations listed below. (Level A)"
...
"Time-Based Media:  If non-text content is time-based media, then text alternatives at least provide descriptive identification of the non-text content"
http://www.w3.org/TR/WCAG20/#text-equiv-all

> http://www.hb9bza.net/netcam/
> http://www.goldengatebridge.org/
> http://observatories.hodar.com/webcams.html

Right now I can not access these examples. I'm on 56K dialup, with images turned off. And video grinds everything to a halt so I don't bother with it here at home.

For general advice, the "HTML5: Techniques for providing useful text alternatives" document is spot on. It says:

"To determine appropriate text alternatives it is important to think about why an image is being included in a document. What is its purpose? Thinking like this will help you to understand what is important about the image for the page's intended audience. Every image has a reason for being on a page because it either provides useful information, performs a function, or enhances aesthetics. Therefore, knowing what the image is for, makes writing appropriate text alternatives easier."

So evaluate the purpose of the webcam image. 

Much of the time, a short text description will be sufficient. That's what I would like to know right now about the example images that you are linking to. What are they? Providing a short text alternative that identifies would be helpful. 

Steve mentioned "aerial view of geneva" for an alt. That is useful to me right now. It gives me something...instead of nothing. Thanks, Steve. 

Brainstorming this further...

Maybe we need the "missing" attribute suggested in Bug 9213 [2] to crowdsource [3] webcam images? It could be like live-tweeting an event. 

[1] http://dev.w3.org/html5/alt-techniques/
[2] http://www.w3.org/Bugs/Public/show_bug.cgi?id=9213
[3] http://en.wikipedia.org/wiki/Crowdsourcing

Comment 12 Ian 'Hixie' Hickson 2010-03-28 22:07:20 UTC
http://www.hb9bza.net/netcam/ has no video — just a static picture (that is updated every few minutes). If you could take a look (it should be downloadable even over dial-up, that's in fact what I was using when I first starting looking at similar Geneva webcams 15 years ago), and suggest what the alternative text should look like, that would be really helpful.
Comment 13 Laura Carlson 2010-03-29 01:20:52 UTC
(In reply to comment #12)
> http://www.hb9bza.net/netcam/ has no video â just a static picture (that is
> updated every few minutes). If you could take a look (it should be downloadable
> even over dial-up, that's in fact what I was using when I first starting
> looking at similar Geneva webcams 15 years ago), and suggest what the
> alternative text should look like, that would be really helpful.

I think Maciej and Steve are both right on track for that example.

The key is to ask yourself what the purpose of what the Webcam is, Ian. To me, the purpose of the image seems to be to show the weather in Geneva and it does so from a rooftop angle of view at set times. So a base text alternative like the following may be worth considering:

alt="A WeatherCam rooftop view of Geneva, Switzerland. Scene updated every ten minutes."

However, I wonder if it would  be possible to have the alt updated with date, time, temp etc with some type of system to match the visual aspect of the WeatherCam? That would be more helpful. That type of info is inserted into the image so why cant it be added to the alt automatically? That text might read along the lines of:
 
alt="A WeatherCam rooftop view of Geneva, Switzerland. 29 March 2010, 2 AM, 10 degrees Celsius, 50 degrees Fahrenheit, 69 percent humidity. Clear sky."

Think about it a bit. A suitable alt will come to you, Ian. Steve is working on WebCam  alt examples  too.  Between the two of you I'm sure HTML5 will get some good samples. Thanks.

The crowdsourcing thing might be good to add further details.


Comment 14 Ian 'Hixie' Hickson 2010-03-29 03:11:29 UTC
> alt="A WeatherCam rooftop view of Geneva, Switzerland. Scene updated every ten
> minutes."

I strongly disagree that this is suitable alt="" text. I think it's a caption, and should be put in a title="" attribute, <figcaption> element, or equivalent.

Confusing captions and replacements is IMHO a huge mistake. WCAG 1 and 2 were unable to make this distinction because HTML4 didn't support it (WCAG2 only talks about "text alternatives", it doesn't say how to distinguish text alternatives that are replacements from those that are merely captions). With HTML5 we _can_ support it, and we should. Making such improvements is the only way we can actually make progress. We simply can't afford to just stay stuck with decade-old decisions: we have to learn from our past mistakes and make things better.

Once we have replacement text and caption text clearly differentiated, we can have user agents present images in suitable and accessible ways: either just replacing the image wholesale when a complete replacement is available (the ideal case, where the user never needs to know there was an image in the first place), or letting the user know an important image is in the content and telling the user the image's caption. This leads to a better user experience.


EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are satisfied with this response, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:
   http://dev.w3.org/html5/decision-policy/decision-policy.html

Status: Rejected
Change Description: no spec change
Rationale: The problem described in the bug description is not a bug. It's an improvement over HTML4 and will actually improve the accessibility of content by reducing the number of images that are called out to the user and making the few that are called out be more clearly understandable.

Note that the suggestion in HTML5 is not that no "text alternative" be provided — merely that the text alternative be semantically marked up correctly as a caption (title="") and not as a replacement (alt=""). This does not contradict WCAG2 advice, as WCAG2 (1.1.1) does not specify what attribute to use.
Comment 15 Michael Cooper 2010-08-31 14:06:09 UTC
http://lists.w3.org/Archives/Public/public-html-a11y/2010Aug/0124.html

The bug triage sub-team believes the HTML A11Y TF should take up this bug. Additional notes may follow in a separate comment.
Comment 16 Michael Cooper 2010-09-02 13:20:49 UTC
Bug triage sub-team says this should be reopened to consider advice of accessibility specialists more. Assigning to Steve Faulkner to provide additional info.
Comment 17 Ian 'Hixie' Hickson 2010-11-03 07:42:57 UTC
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are satisfied with this response, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:
   http://dev.w3.org/html5/decision-policy/decision-policy.html

Status: Rejected
Change Description: no spec change
Rationale: No new information since comment 14.

(In reply to comment #16)
> Bug triage sub-team says this should be reopened to consider advice of
> accessibility specialists more.

Note that I'll consider advice from anyone, not just self-styled "accessibility specialists", if it makes sense. I'm certainly not going to take anyone's advice when it doesn't make sense, though, whatever their qualifications.
Comment 18 John Foliot 2012-12-11 18:33:33 UTC
Move to HTML5: Techniques for providing useful text alternatives - http://dev.w3.org/html5/alt-techniques/
Comment 19 Laura Carlson 2012-12-11 20:57:51 UTC
Hi John,

I know there is already an example in Steve's doc as I requested it in the first place in Bug 9174.

The whole point is that the Steve's document and HTML5 are in conflict. This bug has NOT been fixed in HTML5 proper.

I am marking this bug as TrackerRequest to escalate it to an ISSUE.  

Suggested tracker title: Provide a Webcam example that is in accord with WCAG 2 or Defer to "HTML5: Techniques for providing useful text alternatives" 

Tracker Description:

Currently the HTML5 Spec contains the text:

<blockquote cite="http://www.w3.org/html/wg/drafts/html/CR/embedded-content-0.html#unknown-images">
the image is obtained in some automated fashion without any associated alternative text (e.g. a Webcam)
</blockquote>

There would always be something a person could provide for Webcam text so that it is in accord with WCAG 2. Please REMOVE the offending text completely and link to "HTML5: Techniques for providing useful text alternatives":
http://dev.w3.org/html5/alt-techniques/#sec10 as a webcam example has be added there per bug 9215.
https://www.w3.org/Bugs/Public/show_bug.cgi?id=9215
Comment 20 steve faulkner 2013-01-09 16:38:03 UTC
propose that as part of the work to resolve the overarching issues with alt advice in HTML5 we add an example to the spec taking http://dev.w3.org/html5/alt-techniques/#sec10 as the basis for the addition.
Comment 21 Laura Carlson 2013-01-09 16:49:56 UTC
Hi Steve,

(In reply to comment #20)
> propose that as part of the work to resolve the overarching issues with alt
> advice in HTML5 we add an example to the spec taking
> http://dev.w3.org/html5/alt-techniques/#sec10 as the basis for the addition.

Removing Ian's advice and inserting yours would solve this bug. If/when that is accomplished, I'll remove the tracker request.

Thank you very much Steve.
Comment 22 Sam Ruby 2013-01-09 16:58:21 UTC
TrackerRequest is for bugs in RESOLVED state.
Comment 23 Laura Carlson 2013-01-09 17:42:22 UTC
Hi Sam,

(In reply to comment #22)
> TrackerRequest is for bugs in RESOLVED state.

So how long is it going to take to resolve it now Sam? Another three years?

Quite the manipulation game you are playing. Keep delaying until it is too late. It is the same type of thing you did to longdesc.
Comment 24 Maciej Stachowiak 2013-01-14 21:53:15 UTC
(In reply to comment #23)
> Hi Sam,
> 
> (In reply to comment #22)
> > TrackerRequest is for bugs in RESOLVED state.
> 
> So how long is it going to take to resolve it now Sam? Another three years?
> 
> Quite the manipulation game you are playing. Keep delaying until it is too
> late. It is the same type of thing you did to longdesc.

Laura, please stay constructive. Personal attacks and expressions of anger/outrage are not appropriate for bugzilla. You have done it multiple times now, another example is here: <https://www.w3.org/Bugs/Public/show_bug.cgi?id=9216#c13>. If you continue to post abusive comments in bugzilla, you will be banned from commenting.
Comment 25 steve faulkner 2013-07-11 21:23:22 UTC
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are
satisfied with this response, please change the state of this bug to CLOSED. If
you have additional information and would like the Editor to reconsider, please
reopen this bug. If you would like to escalate the issue to the full HTML
Working Group, please add the TrackerRequest keyword to this bug, and suggest
title and text for the Tracker Issue; or you may create a Tracker Issue
yourself, if you are able to do so. For more details, see this document:

   http://dev.w3.org/html5/decision-policy/decision-policy.html

Status: Accepted
Change Description: added example to spec http://www.w3.org/html/wg/drafts/html/master/embedded-content-0.html#webcam-images
Rationale: obviously an image use that people have trouble with when it comes to providing alt, so provided an example to help
Comment 26 Laura Carlson 2013-07-15 17:28:27 UTC
Thanks, Steve
Comment 27 dmacdona 2013-07-16 01:42:09 UTC
It would be better if the text information was not included in the image, but as it is part of the image, include it <add>as</add> part of the text alternative.