This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 789 - page marked as invalid with no extra information
Summary: page marked as invalid with no extra information
Status: RESOLVED FIXED
Alias: None
Product: Validator
Classification: Unclassified
Component: check (show other bugs)
Version: 0.6.6
Hardware: Other other
: P2 major
Target Milestone: ---
Assignee: Terje Bless
QA Contact: qa-dev tracking
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 856
  Show dependency treegraph
 
Reported: 2004-06-08 12:53 UTC by S
Modified: 2005-02-05 04:22 UTC (History)
0 users

See Also:


Attachments

Description S 2004-06-08 12:53:41 UTC
I mistakenly wrote at the beginning of my HTML document:

<?xml version="1.0" encoding="ISO-8859-1">

instead of

<?xml version="1.0" encoding="ISO-8859-1"?>

The validator first made me replace 
<img.../> with <img...>, <hr/> with <hr>,
and <meta.../> with <meta...>.

Then it complained the page was invalid but gave no line number,
no error message, just an inch of blank background and the standard
footer.
Comment 1 Bj 2004-10-08 21:05:17 UTC
S├ębastien, could you please attach a minimal sample document that we can use to 
reproduce this problem to the bug report?
Comment 2 Terje Bless 2005-02-05 04:22:49 UTC
This is a case of the DOCTYPE getting lost due to an unterminated
XML Declaration PI. This has been fixed in CVS in the course of
cleaning up fallback behaviour.