This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 7253 - <video>: Provide a way to let the browser know what's coming next, for gapless playback
Summary: <video>: Provide a way to let the browser know what's coming next, for gaples...
Status: RESOLVED WONTFIX
Alias: None
Product: WHATWG
Classification: Unclassified
Component: HTML (show other bugs)
Version: unspecified
Hardware: All All
: P3 enhancement
Target Milestone: Needs Impl Interest
Assignee: Ian 'Hixie' Hickson
QA Contact: contributor
URL: http://whatwg.org/specs/web-apps/curr...
Whiteboard:
Keywords:
: 7254 (view as bug list)
Depends on:
Blocks: 10711
  Show dependency treegraph
 
Reported: 2009-08-10 20:00 UTC by contributor
Modified: 2017-07-21 10:31 UTC (History)
10 users (show)

See Also:


Attachments

Description contributor 2009-08-10 20:00:07 UTC
Section: http://whatwg.org/specs/web-apps/current-work/#audio

Comment:
Media elements should provide a "next" property to gaplessly play back another media object after it has finished. This woud allow proper playback of gapless albums and an in-browser implementation of HTTP Adaptive Bitrate Streaming.

Posted from: 209.251.142.125
Comment 1 Ian 'Hixie' Hickson 2009-09-09 09:07:20 UTC
Agreed, but let's wait til we have good implementation experience on the current API before adding more. Deferring to a future version.
Comment 2 Ian 'Hixie' Hickson 2009-09-09 09:08:19 UTC
*** Bug 7254 has been marked as a duplicate of this bug. ***
Comment 3 Maciej Stachowiak 2010-03-14 14:48:55 UTC
This bug predates the HTML Working Group Decision Policy.

If you are satisfied with the resolution of this bug, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:
  http://dev.w3.org/html5/decision-policy/decision-policy.html

This bug is now being moved to VERIFIED. Please respond within two weeks. If this bug is not closed, reopened or escalated within two weeks, it may be marked as NoReply and will no longer be considered a pending comment.
Comment 4 public-rdfa-wg 2013-01-24 06:38:19 UTC
This bug was cloned to create HTML WG bug 19057.
Comment 5 Ian 'Hixie' Hickson 2013-03-19 00:14:49 UTC
Are any browser vendors interested in doing something like this?
Comment 6 Silvia Pfeiffer 2013-03-27 01:02:24 UTC
For the last 3 years at FOMS we have had discussions of gapless playback.

Here are some notes from those meetings:
* http://www.foms-workshop.org/foms2012/pmwiki.php/Main/CollabBrowserDevs ("smooth playback" in the "Asset loading control" section)
* http://www.openmediadevelopers.org/pmwiki.php/Main/OVC2011GaplessPlayback

You will note that in 2011 the discussion about gapless playback included also a discussion about playlists. They are intertwined issues.
Comment 7 Philip J├Ągenstedt 2014-10-08 12:06:05 UTC
This would require coordinating the backends of two media elements, which is a bit like MediaController. No one has put in the engineering effort to implement MediaController correctly yet, so I'm a bit skeptical of this.

Note that if the containers and codecs of two audio files are the same, you should be able to use Media Source Extensions to play them gaplessly. It should also be possible using the Web Audio API, although possibly only if both files are fully loaded and decoded in advance. Splitting into chunks would help, and make it kind of like the MSE case.
Comment 8 Silvia Pfeiffer 2014-10-12 11:37:12 UTC
I think people are doing it now by preloading the next media resource in a hidden media element. I can live with that for now.
Comment 9 Philip J├Ągenstedt 2014-10-13 20:52:08 UTC
That doesn't get you gapless playback, but I can live with that too :)
Comment 10 Anne 2017-07-21 10:31:08 UTC
Please file a new issue at https://github.com/whatwg/html/issues/new if there's still interest.