Bug 19057 - Media elements should provide a "next" property to gaplessly play back another media object after it has finished. This woud allow proper playback of gapless albums and an in-browser implementation of HTTP Adaptive Bitrate Streaming.
Media elements should provide a "next" property to gaplessly play back anothe...
Status: RESOLVED LATER
Product: HTML WG
Classification: Unclassified
Component: HTML5 spec
unspecified
All All
: P3 normal
: ---
Assigned To: This bug has no owner yet - up for the taking
HTML WG Bugzilla archive list
http://whatwg.org/specs/web-apps/curr...
: NoReply
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 22:01 UTC by contributor
Modified: 2012-09-25 22:27 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description contributor 2012-09-25 22:01:45 UTC
This was was cloned from bug 7253 as part of operation LATER convergence.
Originally filed: 2009-08-10 20:00:00 +0000

================================================================================
 #0   contributor@whatwg.org                          2009-08-10 20:00:07 +0000 
--------------------------------------------------------------------------------
Section: http://whatwg.org/specs/web-apps/current-work/#audio

Comment:
Media elements should provide a "next" property to gaplessly play back another media object after it has finished. This woud allow proper playback of gapless albums and an in-browser implementation of HTTP Adaptive Bitrate Streaming.

Posted from: 209.251.142.125
================================================================================
 #1   Ian 'Hixie' Hickson                             2009-09-09 09:07:20 +0000 
--------------------------------------------------------------------------------
Agreed, but let's wait til we have good implementation experience on the current API before adding more. Deferring to a future version.
================================================================================
 #2   Ian 'Hixie' Hickson                             2009-09-09 09:08:19 +0000 
--------------------------------------------------------------------------------
*** Bug 7254 has been marked as a duplicate of this bug. ***
================================================================================
 #3   Maciej Stachowiak                               2010-03-14 14:48:55 +0000 
--------------------------------------------------------------------------------
This bug predates the HTML Working Group Decision Policy.

If you are satisfied with the resolution of this bug, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:
  http://dev.w3.org/html5/decision-policy/decision-policy.html

This bug is now being moved to VERIFIED. Please respond within two weeks. If this bug is not closed, reopened or escalated within two weeks, it may be marked as NoReply and will no longer be considered a pending comment.
================================================================================