This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 57 - Validator requires perl >= 5.6.0
Summary: Validator requires perl >= 5.6.0
Alias: None
Product: Validator
Classification: Unclassified
Component: check (show other bugs)
Version: 0.6.0b1
Hardware: All other
: P2 normal
Target Milestone: ---
Assignee: Terje Bless
QA Contact:
Depends on:
Reported: 2002-10-27 14:20 UTC by Ville Skyttä
Modified: 2005-02-03 17:35 UTC (History)
0 users

See Also:


Description Ville Skyttä 2002-10-27 14:20:02 UTC
The "warnings" pragma was introduced in Perl 5.6.0, so validator doesn't work
with older Perls than that.  (At least) two alternatives:

1) Bump the minimum required version to 5.6.0.
2) Use -w and "local $^W = 0" instead of "use warnings" and "no warnings ...".
Comment 1 Terje Bless 2002-10-28 05:12:39 UTC
Hmmm. I'm leaning towards requiring 5.6.0 (but I've always been a bit agressive
with updates).

The current targets in the Linux world all ship with Perl > 5.60, ActiveState is
at 5.6.1+, and Mac OS X (10.1.x and 10.2.x) ships with Perl 5.6.1. That leaves
the *BSDs and the proprietary UN*X vendors. Anyone know what they're doing?
Comment 2 Ville Skyttä 2002-10-28 07:56:14 UTC
IIRC the *BSDs have a recent enough Perl available in their ports/packages tree,
if not the default "system" Perl.  +1 for requiring 5.6.0.
Comment 3 Terje Bless 2002-10-30 02:51:22 UTC
Upped minimum version to 5.6.0.