This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 27633 - Make getComputedStyle()'s pseudoElt argument nullable
Summary: Make getComputedStyle()'s pseudoElt argument nullable
Status: RESOLVED FIXED
Alias: None
Product: CSS
Classification: Unclassified
Component: CSSOM (show other bugs)
Version: unspecified
Hardware: PC All
: P2 normal
Target Milestone: ---
Assignee: Simon Pieters
QA Contact: public-css-bugzilla
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-16 23:32 UTC by Philip J├Ągenstedt
Modified: 2014-12-17 09:53 UTC (History)
0 users

See Also:


Attachments

Description Philip J├Ągenstedt 2014-12-16 23:32:02 UTC
I aligned with the spec but had to revert on this detail due to a performance regression:
https://codereview.chromium.org/774203003
https://codereview.chromium.org/774243003

It's jQuery passing null for the pseudoElt argument being stringified to "null" that makes the difference it seems:
https://github.com/jquery/jquery/search?q=getComputedStyle

There's no observable difference, but making it nullable would save other browsers the trouble of trying out the same performance regression.
Comment 1 Simon Pieters 2014-12-17 09:53:27 UTC
https://dvcs.w3.org/hg/csswg/rev/547cd57f5983