Bug 2690 - Direct Input always parses with UTF-8 encoding no matter what
Direct Input always parses with UTF-8 encoding no matter what
Status: RESOLVED DUPLICATE of bug 1833
Product: Validator
Classification: Unclassified
Component: Parser
0.7.1
All All
: P2 normal
: ---
Assigned To: Terje Bless
qa-dev tracking
: Usability
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-10 13:15 UTC by Dominik Jungowski
Modified: 2006-01-10 17:57 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominik Jungowski 2006-01-10 13:15:28 UTC
This is a bug I noticed since the 0.7.1 Release of the Validator:
I use Firefox together with Web Developer. When I hit Tools -> Validate Local
HTML I get the error:

"Sorry, I am unable to validate this document because on line 440  it contained
one or more bytes that I cannot interpret as utf-8  (in other words, the bytes
found are not valid values in the specified Character Encoding). Please check
both the content of the file and the character encoding indication."

When copying the source and validating manually the validation works but in both
cases the validator says "Encoding:	utf-8" although I have defined ISO-8859-1 in
the XHTML Header. When uploading the file and parsing it by URL the validator
detects the document correctly as iso-8859-1.

This is pretty annoying since I cannot use the Web Developer feature anymore for
local files and have to manually validate them by direct input.
Comment 1 Bj 2006-01-10 17:57:53 UTC

*** This bug has been marked as a duplicate of 1833 ***