Bug 21941 - Spaghetti Monster reference is provocative
Summary: Spaghetti Monster reference is provocative
Status: RESOLVED FIXED
Alias: None
Product: HTML WG
Classification: Unclassified
Component: CR HTML5 spec (show other bugs)
Version: unspecified
Hardware: PC Windows NT
: P2 normal
Target Milestone: ---
Assignee: Robin Berjon
QA Contact: HTML WG Bugzilla archive list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-06 19:50 UTC by dmacdona
Modified: 2013-05-24 13:39 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dmacdona 2013-05-06 19:50:01 UTC
Snip from bug 21926 comments 


Hi dave, I think the spaghetti monster example is more asinine than provocative. 

===========snip=========
In the following example, a picture representing the flying spaghetti monster emblem, with each of the left noodly appendages and the right noodly appendages in different images, so that the user can pick the left side or the right side in an adventure.

<h1>The Church</h1>
<p>You come across a flying spaghetti monster. Which side of His
Noodliness do you wish to reach out for?</p>
<p><a href="?go=left" ><img src="fsm-left.png"  alt="Left side. "></a
  ><img src="fsm-middle.png" alt=""
  ><a href="?go=right"><img src="fsm-right.png" alt="Right side."></a></p>

=====snip=========

How about this?

===Start of recommended example==========

In the following example, is a picture representing the British House of Commons, with each each side of the house in different images, so that the user can pick the left side or the right side.

<h1>The House of Commons</h1>
<p>You have come upon the House of Commons, which side would you like to pick</p>
<p><a href="?go=left" ><img src="bhc-left.png"  alt="Left side. "></a
  ><img src="brc-middle.png" alt=""
  ><a href="?go=right"><img src="fsm-right.png" alt="Right side."></a></p>
Comment 1 Robin Berjon 2013-05-07 08:23:20 UTC
I think that the reference is (mis)perceived as provocative because it is titled "The Church", which some people read as "The <insert specific Christian denomination> Church" instead of as short for "The Church of the FSM".
Comment 2 dmacdona 2013-05-07 12:47:45 UTC
I think it is a satire of all religion, rather than against any one religion, or denomination. It is a pretty famous image and represents a hot topic, and ridicules a large group of stakeholders. I think any satire is provocative towards some groups. 

I would suggest a more neutral example.
Comment 3 steve faulkner 2013-05-08 12:19:38 UTC
(In reply to comment #2)
> I think it is a satire of all religion, rather than against any one
> religion, or denomination. It is a pretty famous image and represents a hot
> topic, and ridicules a large group of stakeholders. I think any satire is
> provocative towards some groups. 
> 
> I would suggest a more neutral example.

as part of improving the advice in the alt text section of the spec this example will be reviewed and may well be replaced along with other current examples.
Comment 4 steve faulkner 2013-05-09 06:09:20 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > I think it is a satire of all religion, rather than against any one
> > religion, or denomination. It is a pretty famous image and represents a hot
> > topic, and ridicules a large group of stakeholders. I think any satire is
> > provocative towards some groups. 
> > 
> > I would suggest a more neutral example.
> 
> as part of improving the advice in the alt text section of the spec this
> example will be reviewed and may well be replaced along with other current
> examples.

discussed with robin on IRC yesterday http://krijnhoetmer.nl/irc-logs/html-wg/20130508#l-81

info about FSM http://en.wikipedia.org/wiki/Flying_Spaghetti_Monster includes an image which could be used for the example.
Comment 5 heydon 2013-05-09 09:37:42 UTC
I don't think the spaghetti monster example is especially provocative, I just think it's unclear.

The "crocoduck" has similarly "provocative" connotations (in that it gently teases anyone who does not understand evolution, without calling out particular religions) but I think it makes for a better analogy of the problem.

You see, the crocoduck (http://en.wikipedia.org/wiki/Crocoduck) is a hybrid of a crocodile and a duck. Each of these two anatomical parts could be represented by a separate image that - when displayed together - represent the unified appearance of a crocoduck. The example might read something like this:

===========snip=========

In the following example, two pictures are used to represent an unusual creature called a "crocoduck". The user is cast in the role of a zoologist and must identify the correct pasts.

<h1>The jungle</h1>
<p>In a clearing, you see a perculiar creature whose head doesn't seem to match its body. Could this be the famed "crocoduck"? You'd like to get a closer look, but only if it's safe. Does it have a quacking beak or gnashing jaws?</p>
<div>
<img src="crododuck_head.jpg" alt="a crocodile's fearsome head">
<img src="crododuck_body.jpg" alt="a duck's downy body">
</div>

Who's in? :-)(In reply to comment #4)
> (In reply to comment #3)
> > (In reply to comment #2)
> > > I think it is a satire of all religion, rather than against any one
> > > religion, or denomination. It is a pretty famous image and represents a hot
> > > topic, and ridicules a large group of stakeholders. I think any satire is
> > > provocative towards some groups. 
> > > 
> > > I would suggest a more neutral example.
> > 
> > as part of improving the advice in the alt text section of the spec this
> > example will be reviewed and may well be replaced along with other current
> > examples.
> 
> discussed with robin on IRC yesterday
> http://krijnhoetmer.nl/irc-logs/html-wg/20130508#l-81
> 
> info about FSM http://en.wikipedia.org/wiki/Flying_Spaghetti_Monster
> includes an image which could be used for the example.

I don't think the spaghetti monster example is especially provocative, I just think it's unclear.

The "crocoduck" has similarly "provocative" connotations (in that it gently teases anyone who does not understand evolution, without calling out particular religions) but I think it makes for a better analogy of the problem.

You see, the crocoduck (http://en.wikipedia.org/wiki/Crocoduck) is a hybrid of a crocodile and a duck. Each of these two anatomical parts could be represented by a separate image that - when displayed together - represent the unified appearance of a crocoduck. The example might read something like this:

===========snip=========

In the following example, two pictures are used to represent an unusual creature called a "crocoduck". The user is cast in the role of a zoologist and must identify the correct pasts.

<h1>The jungle</h1>
<p>In a clearing, you see a perculiar creature whose head doesn't seem to match its body. Could this be the famed "crocoduck"? You'd like to get a closer look, but only if it's safe. Does it have a quacking beak or gnashing jaws?</p>
<div>
<img src="crododuck_head.jpg" alt="a crocodile's fearsome head">
<img src="crododuck_body.jpg" alt="a duck's downy body">
</div>

Who's in? :-)
Comment 6 dmacdona 2013-05-09 13:05:30 UTC
interesting IRC conversation... 

I'd rather we choose something that isn't, as stommepoes says, a "goofy" example that pokes fun at people... but since it seems there is an attachment to doing so, I think the crocoduck offends fewer people, because it seems to limit itself to young earth creationists. 

Contrary to what Robin suggests in the IRC, the Spaghetti monster throws a much wider net...  it also goes after anyone who understands the world is over 4 billion years old, and who agrees the theory of evolution explains many of the great things in nature, but who happens to think there might be something beyond this beautiful world, besides a bunch of molecules bouncing against each other.
Comment 7 Robin Berjon 2013-05-09 13:14:44 UTC
(In reply to comment #6)
> Contrary to what Robin suggests in the IRC, the Spaghetti monster throws a
> much wider net...  it also goes after anyone who understands the world is
> over 4 billion years old, and who agrees the theory of evolution explains
> many of the great things in nature, but who happens to think there might be
> something beyond this beautiful world, besides a bunch of molecules bouncing
> against each other.

I understand your concerns, but I assure you that's not the case. See for instance in http://en.wikipedia.org/wiki/Flying_Spaghetti_Monster#History: "I don't have a problem with religion. What I have a problem with is religion posing as science." That's where the FSM comes from.

I'm happy with using a crocoduck instead though.
Comment 8 heydon 2013-05-09 13:55:18 UTC
(In reply to comment #6)
> interesting IRC conversation... 
> 
> I'd rather we choose something that isn't, as stommepoes says, a "goofy"
> example that pokes fun at people... but since it seems there is an
> attachment to doing so, I think the crocoduck offends fewer people, because
> it seems to limit itself to young earth creationists. 
> 
> Contrary to what Robin suggests in the IRC, the Spaghetti monster throws a
> much wider net...  it also goes after anyone who understands the world is
> over 4 billion years old, and who agrees the theory of evolution explains
> many of the great things in nature, but who happens to think there might be
> something beyond this beautiful world, besides a bunch of molecules bouncing
> against each other.

(In reply to comment #7)
> (In reply to comment #6)
> > Contrary to what Robin suggests in the IRC, the Spaghetti monster throws a
> > much wider net...  it also goes after anyone who understands the world is
> > over 4 billion years old, and who agrees the theory of evolution explains
> > many of the great things in nature, but who happens to think there might be
> > something beyond this beautiful world, besides a bunch of molecules bouncing
> > against each other.
> 
> I understand your concerns, but I assure you that's not the case. See for
> instance in http://en.wikipedia.org/wiki/Flying_Spaghetti_Monster#History:
> "I don't have a problem with religion. What I have a problem with is
> religion posing as science." That's where the FSM comes from.
> 
> I'm happy with using a crocoduck instead though.

Thanks for the support!

To my mind, the crocoduck - which is emblematic of a poor understanding of evolutionary theory - does not directly attack a religion or religions. In fact, the "crocoduck" is much loved by creationists because they believe its nonexistence disproves evolution. Atheists, like myself, likewise have affection for the crocoduck because the absurdity that two disparate species should somehow be fused is amusing to us. I imagine this is why Richard Dawkins wears a "crocoduck" tie.

I see nothing wrong with a "goofy" analogy since I believe humour can aid apprehension. I simply think that crocoduck is superior to spaghetti monster because the idea of taking two things and making a new whole (two images with respective alts) is better illustrated by a zoological hybrid. Reaching out to touch a right or left flank of tentacles is a somewhat contrived choice of action in the original example.

In addition, the "crocoduck tie" (http://knowyourmeme.com/photos/342825-crocoduck) is reportedly (according to Wikipedia) created by a Web Designer (Josh Timonen). I think this ties things up nicely, no pun intended.
Comment 9 dmacdona 2013-05-09 14:16:08 UTC
I will not object to the crocoduck...

As for the spaghetti monster, I think it is a different beast... without claiming any expertise whatsoever in the field. The history pointed to above is a struggle not over creationism teaching, which is basically junk science, but against ID, which makes no reference to God, or religion (and therefore, no need for an alternate god like a Spaghetti monster)... It says the world is 4 billion years old, and has all kinds of evolutionary forces happening that it seems like everything fits together very well, and this seems to indicate that it was designed, and is not random.  

It may or may not be the case, but it is a serious theory. I don't see any reason to put the disciplines of education into such strict silos that there can be no cross discussion ... the great thinkers of history drift easily between science and philosophy... and even in our present age Richard Dawkins seems to be comfortable doing so in his theories.
Comment 10 heydon 2013-05-09 16:57:15 UTC
(In reply to comment #9)
> I will not object to the crocoduck...
> 
> As for the spaghetti monster, I think it is a different beast... without
> claiming any expertise whatsoever in the field. The history pointed to above
> is a struggle not over creationism teaching, which is basically junk
> science, but against ID, which makes no reference to God, or religion (and
> therefore, no need for an alternate god like a Spaghetti monster)... It says
> the world is 4 billion years old, and has all kinds of evolutionary forces
> happening that it seems like everything fits together very well, and this
> seems to indicate that it was designed, and is not random.  
> 
> It may or may not be the case, but it is a serious theory. I don't see any
> reason to put the disciplines of education into such strict silos that there
> can be no cross discussion ... the great thinkers of history drift easily
> between science and philosophy... and even in our present age Richard
> Dawkins seems to be comfortable doing so in his theories.

(In reply to comment #9)
> I will not object to the crocoduck...
> 
> As for the spaghetti monster, I think it is a different beast... without
> claiming any expertise whatsoever in the field. The history pointed to above
> is a struggle not over creationism teaching, which is basically junk
> science, but against ID, which makes no reference to God, or religion (and
> therefore, no need for an alternate god like a Spaghetti monster)... It says
> the world is 4 billion years old, and has all kinds of evolutionary forces
> happening that it seems like everything fits together very well, and this
> seems to indicate that it was designed, and is not random.  
> 
> It may or may not be the case, but it is a serious theory. I don't see any
> reason to put the disciplines of education into such strict silos that there
> can be no cross discussion ... the great thinkers of history drift easily
> between science and philosophy... and even in our present age Richard
> Dawkins seems to be comfortable doing so in his theories.

Great, I'd be happy to write the crocoduck example in full (without typo's!)

On a personal note, I'm glad my country, England, has no blasphemy laws, allowing me to question dogma of all kinds without fear of legal retribution. While people should have a right to their own beliefs, in no case should those beliefs be protected from scrutiny. 

I have no ideological problem with The Spag' Monster. I just think it's unhelpfully contrived.

Thanks, everyone.
Comment 11 dmacdona 2013-05-09 19:00:25 UTC
>>On a personal note, I'm glad my country, England, has no blasphemy laws, >>allowing me to question dogma of all kinds without fear of legal retribution.

Me too, hope there never are blasphemy laws of any kind, especially hope there will never be a problem openly questioning the status quo.
Comment 12 heydon 2013-05-09 19:12:51 UTC
(In reply to comment #11)
> >>On a personal note, I'm glad my country, England, has no blasphemy laws, >>allowing me to question dogma of all kinds without fear of legal retribution.
> 
> Me too, hope there never are blasphemy laws of any kind, especially hope
> there will never be a problem openly questioning the status quo.

Of course! You may be interested to know that England had a dormant blasphemy law until 2008 (!!) though. Cheers, David, and if I can be of any more assistance with this, ping me.
Comment 13 Šime Vidas 2013-05-11 01:33:13 UTC
(In reply to comment #9)
> …but against ID, which makes no reference to God, or religion (and
> therefore, no need for an alternate god like a Spaghetti monster)... It says
> the world is 4 billion years old, and has all kinds of evolutionary forces
> happening that it seems like everything fits together very well, and this
> seems to indicate that it was designed, and is not random.  
> 
> It may or may not be the case, but it is a serious theory.

Correction: ID is not a scientific theory.
Comment 14 heydon 2013-05-13 11:00:35 UTC
(In reply to comment #11)
> >>On a personal note, I'm glad my country, England, has no blasphemy laws, >>allowing me to question dogma of all kinds without fear of legal retribution.
> 
> Me too, hope there never are blasphemy laws of any kind, especially hope
> there will never be a problem openly questioning the status quo.

Here is the fully reworked example, using the crocoduck instead of the Flying Spaghetti Monster. I've tried to improve the example by making the choice of image-represented action _not_ arbitrary, as it seems in the original (which Spaghetti Monster flank - right or left - represents a preferable action??)

=============== crocoduck example ============================

4.8.1.1.9 Multiple images that form a single larger picture with links

Sometimes, when you create a composite picture from multiple <img>s, you may wish to link one or more of the <img>s. Each linked <img> should have an alt attribute to help describe the purpose of the link.

In the following example, a composite picture is used to represent a "crocoduck" which is a mythical creature; part crocodile and part duck. You are asked to interact with the crocoduck, but you need to exercise caution...

<h1>The crocoduck</h1>
<p>You encounter a strange creature called a "crocoduck". The creature seems angry! Perhaps some friendly stroking will help to calm it, but I'd keep your hand away from the beast's snapping jaws.</p>

<div class="crocoduck">
	<a href="?stroke=head"><img src="crocoduck_1.jpg" alt="crocodile's angry, chomping head"/></a>
	<a href="?stroke=body"><img src="crocoduck_2.jpg" alt="duck's soft, feathery body"/></a>
</div>

=============== end crocoduck example ========================

Any comments?

Cheers - Heydon
Comment 15 dmacdona 2013-05-22 00:40:00 UTC
(In reply to comment #13)
> (In reply to comment #9)
> > …but against ID, which makes no reference to God, or religion (and
> > therefore, no need for an alternate god like a Spaghetti monster)... It says
> > the world is 4 billion years old, and has all kinds of evolutionary forces
> > happening that it seems like everything fits together very well, and this
> > seems to indicate that it was designed, and is not random.  
> > 
> > It may or may not be the case, but it is a serious theory.
> 
> Correction: ID is not a scientific theory.

My post didn't say that it was or wasn't a scientific theory, only that it was a serious theory, and that the greatest minds of history are not limited to silos of observable and non-observable realities. Einstein said "In view of such harmony in the cosmos which I, with my limited human mind, am able to recognize, there are yet people who say there is no God. But what really makes me angry is that they quote me for the support of such views." http://en.wikipedia.org/wiki/Religious_views_of_Albert_Einstein.

However, if ID is *not* a scientific theory, then neither is the assertion that the universe is nothing but random atoms with *no* intelligence behind it.
Comment 16 Robin Berjon 2013-05-22 07:31:56 UTC
Folks,

while you're all staying relatively civil in what can be an otherwise heated discussion, may I please ask you all to keep epistemological, metaphysical, pataphysical, etc. out of Bugzilla?

If nothing else, I'd like to remind everyone here that my only higher education happens to be in philosophy. If you make me join the debate, we're all going to have a bad time.

So can we just run with the crocoduck?

Thank you!
Comment 17 dmacdona 2013-05-22 08:33:01 UTC
I agree with Robin that the crocoduck example makes more programmatic sense, and I think it is less strident than the current example... I do not object to it replacing the current example.

The last thing I want to do is enter into debate, too much work to do here on earth. Happy to change it and move on.
Comment 18 steve faulkner 2013-05-22 08:35:23 UTC
Note: I am working on a major rewrite of the alt text advice in the spec and will incorporate crocoduck as part of that commit for further review.
Comment 19 steve faulkner 2013-05-24 10:42:23 UTC
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are satisfied with this response, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:
   http://dev.w3.org/html5/decision-policy/decision-policy.html

Status: accepted
Change Description: updated example 
http://www.w3.org/html/wg/drafts/html/master/embedded-content-0.html#a-group-of-images-that-form-a-single-larger-picture-with-links
commit: https://github.com/w3c/html/commit/1cb3a66062eddfd3eff2804c8cf359ebc9e004c1

Rationale: its an example only, better to provide an improved alternative that doesn't ruffle feathers and move on.
Comment 20 steve faulkner 2013-05-24 10:53:22 UTC
note is currently only updated in html 5.1 next step is html5 CR
Comment 21 dmacdona 2013-05-24 13:39:14 UTC
Accepted, thanks