Bug 21084 - Clarify that only certain attributes need translation, such as alt="", title="", lang="", perhaps href="", hreflang="", but not attributes such as class=""/id=""/style="".
Summary: Clarify that only certain attributes need translation, such as alt="", title=...
Status: RESOLVED FIXED
Alias: None
Product: WHATWG
Classification: Unclassified
Component: HTML (show other bugs)
Version: unspecified
Hardware: Other other
: P3 normal
Target Milestone: Unsorted
Assignee: Ian 'Hixie' Hickson
QA Contact: contributor
URL: http://www.whatwg.org/specs/web-apps/...
Whiteboard:
Keywords:
: 21085 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-22 09:37 UTC by contributor
Modified: 2013-04-04 15:24 UTC (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description contributor 2013-02-22 09:37:17 UTC
Specification: http://www.whatwg.org/specs/web-apps/current-work/
Multipage: http://www.whatwg.org/C#the-translate-attribute
Complete: http://www.whatwg.org/c#the-translate-attribute

Comment:
Clarify that only certain attributes need translation, such as alt="",
title="", lang="", perhaps href="", hreflang="", but not attributes such as
class=""/id=""/style="".

Posted from: 207.218.72.65
User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.10 Safari/537.31
Comment 1 Anne 2013-02-22 09:38:50 UTC
*** Bug 21085 has been marked as a duplicate of this bug. ***
Comment 2 Anne 2013-02-22 09:39:11 UTC
See also http://lists.w3.org/Archives/Public/www-international/2013JanMar/0257.html and the resulting thread.
Comment 3 Norbert Lindenberg 2013-02-28 06:12:19 UTC
href and hreflang are not translatable, although they may be localizable. We had a discussion about this recently while reviewing the ITS 2.0 specification, and the emerging consensus is that eventually there needs to be another attribute to identify localizable items separately from translatable ones:
http://www.w3.org/International/track/issues/217
Comment 4 Anne 2013-03-11 17:42:03 UTC
Looks like http://html5.org/r/7745 is the relevant change.