Bug 20689 - Specify how CDM should indicate successful completion with no message for server
Specify how CDM should indicate successful completion with no message for server
Status: RESOLVED DUPLICATE of bug 21854
Product: HTML WG
Classification: Unclassified
Component: Encrypted Media Extensions
unspecified
All All
: P3 normal
: ---
Assigned To: Adrian Bateman [MSFT]
HTML WG Bugzilla archive list
:
Depends on: 20688
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-16 23:26 UTC by David Dorwin
Modified: 2013-04-26 21:15 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Dorwin 2013-01-16 23:26:33 UTC
Some key systems may wish to indicate "the CDM did what the app asked but has nothing to send to the server". This may also be an indication that a MediaKeySession has been initialized and is ready for use.

The keyadded event currently serves this purpose in a specific case. We could generalize it (option #3 in bug 20688).

Otherwise, we may want to define a way to indicate "the CDM did what the app asked but has nothing to send to the server". If not keyadded (or its successor), keymessage along with an "empty" message attribute makes sense.

We would then need to decide whether "empty" is an empty array or null. The former seems less likely to cause problems with apps that don't consider this case.
Comment 1 David Dorwin 2013-04-23 16:36:04 UTC
We may resolve bug 20688 in a way that addresses this (i.e. keyadded becomes "done").
Comment 2 Adrian Bateman [MSFT] 2013-04-24 21:35:06 UTC
I think this is a duplicate of Bug 19208.
Comment 3 David Dorwin 2013-04-26 21:15:09 UTC

*** This bug has been marked as a duplicate of bug 21854 ***