Bug 19683 - [XQ30] Section 4.20 require-feature and prohibit-feature not updated?
[XQ30] Section 4.20 require-feature and prohibit-feature not updated?
Status: RESOLVED FIXED
Product: XPath / XQuery / XSLT
Classification: Unclassified
Component: XQuery 3.0
Working drafts
All All
: P2 normal
: ---
Assigned To: Jonathan Robie
Mailing list for public feedback on specs from XSL and XML Query WGs
:
: 19599 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 01:53 UTC by Jim Melton
Modified: 2012-10-29 16:59 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Melton 2012-10-24 01:53:19 UTC
In section 4.20 require-feature and prohibit-feature (of the XQuery 3.0 draft found at https://www.w3.org/XML/Group/qtspecs/specifications/xquery-30/html/xquery-30.html , I read the following:

<text>
In XQuery 3.0, the following feature names may be used in require-feature or prohibit-feature option declarations; they are all defined in the http://www.w3.org/2012/xquery namespace.

    The name schema-import corresponds to the feature defined in 5.2.1 Schema Import Feature.

    The name schema-validation corresponds to the feature defined in 5.2.2 Schema Validation Feature.

    The name static-typing corresponds to the feature defined in 5.2.4 Static Typing Feature.

    The name module corresponds to the feature defined in 5.2.5 Module Feature.

    The name serialization corresponds to the feature defined in 5.2.6 Serialization Feature.
</text>

However, there is no feature named "Schema Import Feature", nor is there a feature named "Schema Validation Feature". They have been replaced by a feature named "Schema Aware Feature".  This can be seen in section 5.2 Optional Features. 

In addition, section 5.2 Optional Features defines yet another optional feature: 5.2.7 Higher-Order Function Feature.  That new feature is not reflected in section 4.20 require-feature and prohibit-feature.  Consequently, no identifier for that new feature has been defined. 

I strongly suggest that section 4.20 require-feature and prohibit-feature be updated before the F2F next week to reflect the current list of optional features.  (Notice that section 5.2 redundantly defines the feature identifiers that are -- or should be, at least -- also defined in section 4.20. It seems unfortunate to define them twice, as it can only lead to inconsistencies.)
Comment 1 Michael Kay 2012-10-24 08:14:53 UTC
*** Bug 19599 has been marked as a duplicate of this bug. ***
Comment 2 Jonathan Robie 2012-10-29 16:59:55 UTC
The Editor will fix this.