Bug 19056 - Need to expose media metadata properties
Summary: Need to expose media metadata properties
Status: RESOLVED LATER
Alias: None
Product: HTML WG
Classification: Unclassified
Component: HTML5 spec (show other bugs)
Version: unspecified
Hardware: All All
: P2 normal
Target Milestone: ---
Assignee: This bug has no owner yet - up for the taking
QA Contact: HTML WG Bugzilla archive list
URL: http://esw.w3.org/topic/HTML/UANormAn...
Whiteboard:
Keywords: NoReply
: 15401 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-09-25 22:01 UTC by contributor
Modified: 2013-02-12 19:49 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description contributor 2012-09-25 22:01:34 UTC
This was was cloned from bug 5755 as part of operation LATER convergence.
Originally filed: 2008-06-14 10:39:00 +0000
Original reporter: Rob Burns <rob@robburns.com>

================================================================================
 #0   Rob Burns                                       2008-06-14 10:39:17 +0000 
--------------------------------------------------------------------------------
* users want (and sometimes need) access to metadata stored within various media formats
 * often immanent metadata properties are better way to store metadata for authors and users so that these properties do not become separated from the file, but UAs often lack a mechanism to access that metadata stored in that way

(see http://esw.w3.org/topic/HTML/UANormAndDOMForMediaPropeties for evolving solution proposals)


[user issue, authoring issue]
================================================================================
 #1   Ian 'Hixie' Hickson                             2008-06-14 18:39:55 +0000 
--------------------------------------------------------------------------------
Exposing media data in <video> and <audio> is an existing v3 feature proposal.
================================================================================
 #2   Rob Burns                                       2008-06-16 11:49:39 +0000 
--------------------------------------------------------------------------------
(in reply to comment #1)
What is v3? How does that relate to this bug in the HTML5 draft?
================================================================================
 #3   Ian 'Hixie' Hickson                             2008-06-16 20:29:43 +0000 
--------------------------------------------------------------------------------
v3 means "version 3" (as in, the third major version of the media feature). v1 was the original proposal with just play and pause. v2 is the current feature set, which is much bigger. Once all the major user agents implement that well, and once the risk of distracting them from other parts of the spec becomes lower than the risk of them just doing their own thing with video extensions, then we will go to v3 and add more features, such as this one. You can see the complete list of v3 requests in the spec (search for "v3" in the source).

Marking a bug LATER doesn't mean it is rejected, it just means that I can't do anything with it right now, but will revisit it in future.
================================================================================
 #4   Maciej Stachowiak                               2010-03-14 13:14:16 +0000 
--------------------------------------------------------------------------------
This bug predates the HTML Working Group Decision Policy.

If you are satisfied with the resolution of this bug, please change the state of this bug to CLOSED. If
you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:
   http://dev.w3.org/html5/decision-policy/decision-policy.html

This bug is now being moved to VERIFIED. Please respond within two weeks. If this bug is not closed, reopened or escalated within two weeks, it may be marked as NoReply and will no longer be considered a pending comment.
================================================================================
 #5   Maciej Stachowiak                               2010-04-19 09:31:27 +0000 
--------------------------------------------------------------------------------
No longer waiting for a reply on this bug.
================================================================================
Comment 1 Edward O'Connor 2013-02-12 19:49:24 UTC
*** Bug 15401 has been marked as a duplicate of this bug. ***