Bug 19022 - Syntax of <ol@type> and <ul@type> should be aligned with CSS list-style-type
Summary: Syntax of <ol@type> and <ul@type> should be aligned with CSS list-style-type
Alias: None
Product: HTML WG
Classification: Unclassified
Component: HTML5 spec (show other bugs)
Version: unspecified
Hardware: All All
: P3 normal
Target Milestone: ---
Assignee: This bug has no owner yet - up for the taking
QA Contact: HTML WG Bugzilla archive list
URL: http://dev.w3.org/html5/spec/grouping...
Depends on:
Reported: 2012-09-25 21:54 UTC by contributor
Modified: 2012-09-25 22:27 UTC (History)
5 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description contributor 2012-09-25 21:54:46 UTC
This was was cloned from bug 9799 as part of operation LATER convergence.
Originally filed: 2010-05-22 16:29:00 +0000
Original reporter: Leif Halvard Silli <xn--mlform-iua@xn--mlform-iua.no>

 #0   Leif Halvard Silli                              2010-05-22 16:29:39 +0000 
Bug 9798 says that @type for <ol> and <ul> should be permitted. 

This bug suggests the syntax for the type attribute,


General: change from HTML4 values to CSS values

For <ul> the HTML4 values are indentical with CSS2, and thus can remain. 
In addition the CSS value "none" should also be permitted.

FOr <ol>, the HTML4 values  should become deprecated/obsoleted:

The HTML4 values for ol@type:  1,a,A,i,I
New values from CSS2: decimal | decimal-leading-zero | lower-roman | upper-roman | lower-greek | lower-latin | upper-latin | armenian | georgian | lower-alpha | upper-alpha | none

The value "inherit" should not be permitted.

JUSTIFICATION:  It is practical to have just one value set - namely that of CSS.


Webkit: the CSS synonyms for the HTML4 values, are already supported - other CSS values are not supported. (Interaction with default CSS may cause bugs, however). 

In Gecko: The CSS synonyms for the HTML4 values are already supported. But disabling CSS removes support for @type, regardless of whether it contains CSS values or HTML4 values. 

Opera: supports the HTML4 values - but not the CSS values. Doesn't matter if CSS is enabled or if one disables CSS (to disable CSS, I disable any styling in  "user mode"  - see the Stylesheet menu under the View menut - I don't know if there is a way to disable CSS more fundamentally).

IE: Only support the HTML4 values. The support is not affected if one disables CSS for the current page.
 #1   Ian 'Hixie' Hickson                             2010-08-18 01:25:47 +0000 
I doubt we'll be able to do this, given back-compat, but we should probably at least investigate.
 #2   Ian 'Hixie' Hickson                             2010-09-24 14:59:55 +0000 
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are satisfied with this response, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:

Status: Rejected
Change Description: no spec change
Rationale: I looked into this but on balance I think we're better off not doing this (yet). I'm loathe to introduce synonyms, so for <ol type> I'm skeptical about doing it at all. For <ul type> the only addition at this point would be "none" and I don't see the use of that. Maybe once CSS3 Lists is more complete, we can revisit this, though.
 #3   Ian 'Hixie' Hickson                             2010-10-12 10:12:09 +0000 
*** Bug 11001 has been marked as a duplicate of this bug. ***