Bug 18928 - Update examples to use addEventListener instead of onkeyadded, onkeymessage, and onkeyerror
Update examples to use addEventListener instead of onkeyadded, onkeymessage, ...
Status: RESOLVED FIXED
Product: HTML WG
Classification: Unclassified
Component: Encrypted Media Extensions
unspecified
PC Windows 3.1
: P2 normal
: ---
Assigned To: Adrian Bateman [MSFT]
HTML WG Bugzilla archive list
:
: 19622 19624 19625 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 05:47 UTC by Jer Noble
Modified: 2013-05-03 15:52 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jer Noble 2012-09-20 05:47:49 UTC
The Examples in section 8 add event handlers to MediaKeySession objects by setting its onkeymessage and onkeyerror attributes, but these are not listed in the MediaKeySession IDL.  Please consider adding and documenting these attributes.
Comment 1 Adrian Bateman [MSFT] 2012-09-20 06:43:19 UTC
Since these objects are not defined declaratively, I believe using addEventListener is sufficient and we shouldn't also need to support attributes. Propose WONTFIX.
Comment 2 Jer Noble 2012-09-20 06:56:48 UTC
If that's the case, the example sections will all need to be rewritten, so as not to cause confusion.
Comment 3 David Dorwin 2012-10-29 16:21:45 UTC
*** Bug 19622 has been marked as a duplicate of this bug. ***
Comment 4 David Dorwin 2012-10-29 16:21:57 UTC
*** Bug 19624 has been marked as a duplicate of this bug. ***
Comment 5 David Dorwin 2012-10-29 16:22:16 UTC
*** Bug 19625 has been marked as a duplicate of this bug. ***
Comment 6 David Dorwin 2013-04-23 18:54:15 UTC
Updating the Summary to match our intent.
Comment 7 Adrian Bateman [MSFT] 2013-05-03 15:52:40 UTC
https://dvcs.w3.org/hg/html-media/rev/29422cdbc179