Bug 17494 - JavaScriptAudioNode should be renamed
JavaScriptAudioNode should be renamed
Status: CLOSED DUPLICATE of bug 17348
Product: AudioWG
Classification: Unclassified
Component: Web Audio API
unspecified
PC All
: P2 normal
: TBD
Assigned To: Chris Rogers
public-audio
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 01:14 UTC by Dean Jackson
Modified: 2012-09-10 10:11 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dean Jackson 2012-06-15 01:14:13 UTC
There is nothing inherently JavaScript-ish about the JavaScriptAudioNode. It should have a better name, such as ProceduralSourceNode (that's bad as well - the important point is that JavaScript shouldn't be in the name).
Comment 1 Olivier Thereaux 2012-06-15 10:05:35 UTC
Good point, thanks Dean. Merging this with another similar issue already reported.

*** This bug has been marked as a duplicate of bug 17348 ***
Comment 2 Olivier Thereaux 2012-09-10 10:11:48 UTC
DUP.