Bug 17348 - (JavaScriptAudioNodeName): JavaScriptAudioNode name
(JavaScriptAudioNodeName): JavaScriptAudioNode name
Status: CLOSED FIXED
Product: AudioWG - OBSOLETE - Moved to Github
Classification: Unclassified
Component: Web Audio API - OBSOLETE - See Github
unspecified
PC All
: P2 normal
: TBD
Assigned To: This bug has no owner yet - up for the taking
This bug has no owner yet - up for the taking
:
: 17494 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 11:39 UTC by Philip Jägenstedt
Modified: 2013-07-22 16:03 UTC (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philip Jägenstedt 2012-06-05 11:39:55 UTC
Audio-ISSUE-57 (JavaScriptAudioNodeName): JavaScriptAudioNode name [Web Audio API]

http://www.w3.org/2011/audio/track/issues/57

Raised by: Philip Jägenstedt
On product: Web Audio API

The name is extremely odd for a Web specification, hopefully unprecedented.

>From a spec-lawyering point of view, WebIDL is supposed to be language-agnostic, so it's weird to put the name of a language into the name of an interface. What would it be called in Dart?

Suggestions: CustomAudioNode or CallbackAudioNode.
Comment 1 Olivier Thereaux 2012-06-15 10:05:35 UTC
*** Bug 17494 has been marked as a duplicate of this bug. ***
Comment 2 Jussi Kalliokoski 2012-07-19 14:26:25 UTC
I also suggested that createJavaScriptNode be renamed to createNode. [1]

[1] http://lists.w3.org/Archives/Public/public-audio/2012JulSep/0158.html
Comment 3 Chris Rogers 2012-10-16 20:24:05 UTC
based on: https://www.w3.org/Bugs/Public/show_bug.cgi?id=17407

The name has been changed to ScriptProcessorNode

The suggested create method name is createScriptProcessor()
Comment 4 Olivier Thereaux 2013-07-22 16:03:11 UTC
Resolved by Comment #3
Comment 5 Olivier Thereaux 2013-07-22 16:03:25 UTC
… and closing