Several people have argued to change the name of the 'display' value that triggers flexbox behavior.
Ojan argues to name it 'flex', simply for symmetry with the property prefix.
fantasai and Anton argue that, since the element doesn't actually flex (its children do), it's misleading to call it a "flexbox", though they don't have a good suggestion of what to call it.
Brad suggests 'flex-group'.
(Closely related to this is updating the spec to use terms other than "flexbox" and "flexbox item", for the same reasons that fantasai and Anton give.)
Went with "display:flex"