Bug 16542 - Clarify abstract about "No 'DRM' is added"
Clarify abstract about "No 'DRM' is added"
Status: RESOLVED FIXED
Product: HTML WG
Classification: Unclassified
Component: Encrypted Media Extensions
unspecified
All All
: P3 normal
: ---
Assigned To: Adrian Bateman [MSFT]
HTML WG Bugzilla archive list
http://dvcs.w3.org/hg/html-media/raw-...
:
: 16543 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 18:43 UTC by Adrian Bateman [MSFT]
Modified: 2012-09-01 22:42 UTC (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adrian Bateman [MSFT] 2012-03-27 18:43:10 UTC
The abstract of the spec says "No "DRM" is added to the HTML5 specification, and only simple clear key decryption is required as a common baseline."

This should better describe how the underlying implementation of a DRM/content protection system is not included in this spec, not required to implement the spec, and that the spec mediates access to such a system allowing the page to communicate with a license service as necessary.
Comment 1 Mark Watson 2012-05-30 22:26:57 UTC
(In reply to comment #0)
> The abstract of the spec says "No "DRM" is added to the HTML5 specification,
> and only simple clear key decryption is required as a common baseline."
> 
> This should better describe how the underlying implementation of a DRM/content
> protection system is not included in this spec, not required to implement the
> spec, and that the spec mediates access to such a system allowing the page to
> communicate with a license service as necessary.

I propose the following text to replace the statement above:

"This specification does not define a content protection or Digital Rights Management system. Rather, it defines a common API that may be used to discover, select and interact with such systems as well as with simpler content encryption systems. Implementation of Digital Rights Management is not required for compliance with this specification: only the simple clear key system is required to be implemented as a common baseline.

The common API supports a simple set of content encryption capabilities, leaving application functions such as authentication and authorization to page authors. This is achieved by requiring content protection system-specific messaging to be mediated by the page, rather than assuming out-of-band communication between the Content Decryption Module and a license or other server."
Comment 2 David Dorwin 2012-06-01 19:12:01 UTC
I like it.

nit: We might want to avoid specific terms like "Content Decryption Module" in the abstract. Maybe replace it with "encryption system".
Comment 3 David Dorwin 2012-06-01 19:36:07 UTC
While we're editing the Abstract, we should try to address bug 16543 too. That is, we should have one cohesive update that introduces the document.
Comment 4 Adrian Bateman [MSFT] 2012-08-28 20:51:13 UTC
Assigned to Adrian to add text. Will also ensure that bug 16543 is addressed by this change.
Comment 5 Adrian Bateman [MSFT] 2012-08-28 20:52:48 UTC
*** Bug 16543 has been marked as a duplicate of this bug. ***
Comment 6 Adrian Bateman [MSFT] 2012-09-01 22:42:12 UTC
Fixed. Change set -> http://dvcs.w3.org/hg/html-media/rev/1ca7610af922