Bug 15921 - The WheelEvent.initWheelEvent modifiersListArg parameter should be documented
The WheelEvent.initWheelEvent modifiersListArg parameter should be documented
Status: VERIFIED DUPLICATE of bug 15330
Product: WebAppsWG
Classification: Unclassified
Component: DOM3 Events
unspecified
PC All
: P2 normal
: ---
Assigned To: Travis Leithead [MSFT]
public-webapps-bugzilla
: reviewerSatisfied
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-07 03:38 UTC by Dominic Cooney
Modified: 2012-03-13 00:05 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominic Cooney 2012-02-07 03:38:15 UTC
The documentation for this parameter says:

"Refer to the MouseEvent.initMouseEvent() method for a description of this parameter."

However MouseEvent.initMouseEvent does not have this parameter.
Comment 1 Anne 2012-02-07 09:09:53 UTC
There should not be an initWheelEvent() method to begin with I think.
Comment 2 Dominic Cooney 2012-02-07 09:15:42 UTC
(In reply to comment #1)
> There should not be an initWheelEvent() method to begin with I think.

Implementers have noted that initWheelEvent is widely used <https://bugs.webkit.org/show_bug.cgi?id=68791>.
Comment 3 Travis Leithead [MSFT] 2012-03-08 21:16:57 UTC
Assigning to myself to take action on these open bugs.
Comment 4 Travis Leithead [MSFT] 2012-03-10 00:16:57 UTC
Duping this to Bug 15330 (which came first). They are the same issue. This will be fixed with the next update--I'll resolve it once I've pushed the changes to the server.

*** This bug has been marked as a duplicate of bug 15330 ***
Comment 5 Travis Leithead [MSFT] 2012-03-13 00:03:57 UTC
Duped bug verified--same goes for this one.