Bug 15330 - MouseWheel.initWheelEvent error
MouseWheel.initWheelEvent error
Status: VERIFIED FIXED
Product: WebAppsWG
Classification: Unclassified
Component: DOM3 Events
unspecified
PC Windows NT
: P2 normal
: ---
Assigned To: Travis Leithead [MSFT]
public-webapps-bugzilla
: reviewerSatisfied
: 15921 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-23 23:08 UTC by Brandon Slade
Modified: 2012-03-13 00:02 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brandon Slade 2011-12-23 23:08:51 UTC
In the latest editor's draft (4 Sep. 2011) which can be found at http://dev.w3.org/2006/webapi/DOM-Level-3-Events/html/DOM3-Events.html there is an error in the definition for the MouseWheel.initWheelEvent(...) method. http://dev.w3.org/2006/webapi/DOM-Level-3-Events/html/DOM3-Events.html#events-event-type-initWheelEvent

In it is a parameter called modifiersListArg of type DOMString. The specification tells you to "Refer to the MouseEvent.initMouseEvent() method for a description of this parameter." Following the link to look at initMouseEvent shows that MouseEvent.initMouseEvent does not accept this parameter - in fact, it does not accept any DOMString parameter!

I think that modifiersListArg is an error with the specification. If not, please correct me and tell me what it is for and how to deal with it.

Thanks,
Brandon
Comment 1 Travis Leithead [MSFT] 2012-03-10 00:16:57 UTC
*** Bug 15921 has been marked as a duplicate of this bug. ***
Comment 2 Travis Leithead [MSFT] 2012-03-10 01:11:20 UTC
I've fixed this the easy way by copying the other modifierListArgs parameter (expounding on it a bit) and putting it in the WheelEvent.initWheelEvent's parameter list.

Please see:
http://dev.w3.org/2006/webapi/DOM-Level-3-Events/html/DOM3-Events.html?rev=1.214#events-wheelevents

Brandon, Dominic (duped bug) can you please review and let me know if you believe this issue is fixed?
Comment 3 Brandon Slade 2012-03-10 03:22:06 UTC
It looks fine to me. Thanks for fixing it.
Comment 4 Dominic Cooney 2012-03-12 01:28:31 UTC
Looks good to me.
Comment 5 Travis Leithead [MSFT] 2012-03-13 00:02:49 UTC
Verified by reporter.