Bug 15525 - Support values without units in transformation functions for SVG
Summary: Support values without units in transformation functions for SVG
Status: RESOLVED DUPLICATE of bug 15934
Alias: None
Product: CSS
Classification: Unclassified
Component: Transforms (show other bugs)
Version: unspecified
Hardware: PC All
: P2 normal
Target Milestone: ---
Assignee: Dirk Schulze
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-11 17:26 UTC by Dirk Schulze
Modified: 2012-02-21 04:29 UTC (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Schulze 2012-01-11 17:26:01 UTC
Should CSS transform support values without units in transformation functions? The lack of units is a common use case in SVG Transform.

Should CSS Transform support unit less values in general?
Should CSS Transform just support unit less values for SVG?
Comment 1 Simon Fraser 2012-01-18 16:28:24 UTC
> Should CSS Transform support unit less values in general?
No.

> Should CSS Transform just support unit less values for SVG?
I think so, yes.
Comment 2 Dirk Schulze 2012-02-07 16:18:34 UTC
(In reply to comment #1)
> > Should CSS Transform support unit less values in general?
> No.
> 
> > Should CSS Transform just support unit less values for SVG?
> I think so, yes.

I'd like to discuss this with the CSS WG first. And I really meant in general. The SVG WG wants to move more SVG attributes to presentation attributes. And length values don't need to have units. Values without units doesn't mean that they are unspecified: http://www.w3.org/Graphics/fx/wiki/Merged_Transforms#Parser_issues

This would also be consistent with CSSMatrix which doesn't provide units at all.
Comment 3 Dirk Schulze 2012-02-21 04:29:31 UTC

*** This bug has been marked as a duplicate of bug 15934 ***