Bug 15431 - getComputedStyle().transform should be explicitly required to return numbers for all entries, not lengths
Summary: getComputedStyle().transform should be explicitly required to return numbers ...
Status: RESOLVED DUPLICATE of bug 15797
Alias: None
Product: CSS
Classification: Unclassified
Component: Transforms (show other bugs)
Version: unspecified
Hardware: All All
: P2 normal
Target Milestone: ---
Assignee: Simon Fraser
QA Contact:
Depends on:
Reported: 2012-01-05 20:07 UTC by Aryeh Gregor
Modified: 2012-03-12 21:32 UTC (History)
6 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Aryeh Gregor 2012-01-05 20:07:20 UTC

data:text/html,<!doctype html>
<body style=transform:translate(5px)></div>

If you substitute the appropriate prefixed property for both instances of "translate", IE9, Chrome 17 dev, and Opera Next 12.00 alpha all say "matrix(1, 0, 0, 1, 5, 0)".  Firefox 12.0a1 says "matrix(1, 0, 0, 1, 5px, 0px)".  Which is correct?  The spec suggests the first, but it doesn't say explicitly.  I suggest explicitly stating that a, b, c, d, e, and f are all numbers, not lengths.
Comment 1 Aryeh Gregor 2012-01-19 16:16:35 UTC
Cf. bug 15628.  Even if that bug is FIXED, I think we should still omit the "px" from all matrix entries in getComputedStyle().  Adding the "px" doesn't seem to serve any purpose -- it's shorter without "px", a matrix without "px" works in more browsers right now, and all non-Gecko browsers omit the "px" already.

Mozilla bug: https://bugzilla.mozilla.org/show_bug.cgi?id=719446
Comment 2 Aryeh Gregor 2012-02-22 20:04:34 UTC
All browsers agree now.  I'll make the change when I get CVS access.
Comment 3 Aryeh Gregor 2012-03-07 21:42:38 UTC
This is moot given bug 15797 comment 10.  I'm leaving it open until that's resolved, though.
Comment 4 Aryeh Gregor 2012-03-12 21:32:39 UTC

*** This bug has been marked as a duplicate of bug 15797 ***