Bug 14693 - \ rewriting in URLs never happens?
Summary: \ rewriting in URLs never happens?
Status: RESOLVED DUPLICATE of bug 12543
Alias: None
Product: HTML WG
Classification: Unclassified
Component: HTML5 spec (show other bugs)
Version: unspecified
Hardware: All All
: P2 normal
Target Milestone: ---
Assignee: contributor
QA Contact: HTML WG Bugzilla archive list
URL: http://dev.w3.org/html5/spec/urls.htm...
Whiteboard: Blocked on URL spec
Depends on:
Reported: 2011-11-04 08:50 UTC by Julian Reschke
Modified: 2012-01-25 23:45 UTC (History)
6 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Julian Reschke 2011-11-04 08:50:31 UTC
See <http://lists.w3.org/Archives/Public/www-tag/2011Nov/0015.html>.

It appears that

"12. If result uses a scheme with a server-based naming authority, replace all U+005C REVERSE SOLIDUS (\) characters in result with U+002F SOLIDUS (/) characters."

will never be reached as \ is invalid in URIs, and step 10 is:

"10. Apply any relevant conformance criteria of RFC 3986 and RFC 3987, returning an error and aborting these steps if appropriate. [RFC3986] [RFC3987]".

(To be clear: I'm just pointing out a potential bug in the algorithm; personally I'd prefer not to try rewriting \ in general).
Comment 1 Ian 'Hixie' Hickson 2011-11-11 22:17:59 UTC
Yes, there's all kinds of errors in this algorithm. The idea is to have the algorithm replaced by a reference to a specification that defines how to parse URLs.
Comment 2 Julian Reschke 2011-11-20 21:06:39 UTC
See also bug 12543.
Comment 3 Ian 'Hixie' Hickson 2012-01-25 23:45:02 UTC

*** This bug has been marked as a duplicate of bug 12543 ***