Bug 14659 - 'animation-iteration' event on last iteration
'animation-iteration' event on last iteration
Status: RESOLVED FIXED
Product: CSS
Classification: Unclassified
Component: Animations
unspecified
PC All
: P2 normal
: ---
Assigned To: Dean Jackson
This bug has no owner yet - up for the taking
http://lists.w3.org/Archives/Public/w...
[easy][needsresolution]
:
: 14721 15241 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-01 16:45 UTC by Simon Fraser
Modified: 2012-04-10 23:54 UTC (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Simon Fraser 2012-02-26 17:24:41 UTC
I think we'll just update the wording in the spec so say "every iteration other than the last"?
Comment 2 Simon Fraser 2012-02-26 17:27:05 UTC
*** Bug 14721 has been marked as a duplicate of this bug. ***
Comment 3 Simon Fraser 2012-02-26 17:29:37 UTC
*** Bug 15241 has been marked as a duplicate of this bug. ***
Comment 4 Sylvain Galineau 2012-02-26 23:06:55 UTC
That would match Gecko and Webkit but what is the rationale for that? We could overload animationend to be also the end of the last iteration but we have to be careful how we define what the last iteration is when the iteration count is fractional. Some timeline diagrams may help here.
Comment 5 Sylvain Galineau 2012-04-03 20:37:11 UTC
Current wording:

# The ‘animationiteration’ event occurs at the end of each iteration 
# of an animation for which animation-iteration-count is greater than 
# one. This event does not occur for animations with an iteration count 
# of one. 

Proposed edit:

# The ‘animationiteration’ event occurs at the end of each animation
# iteration other than the last one. This event does not occur for 
# animations with an iteration count of one. 

Should it say 'with an iteration count of one or zero'?
Comment 6 Sylvain Galineau 2012-04-10 23:54:08 UTC
Resolved using dbaron's proposal [1]:

# The 'animationiteration' event occurs at the end of each
# iteration of an animation, except when an 'animationend' event
# would fire at the same time.  This means that this event does
# not occur for animations with an iteration count of one or less.

http://lists.w3.org/Archives/Public/www-style/2012Apr/0235.html