Bug 14632 - Add animationcancelled event
Add animationcancelled event
Status: RESOLVED LATER
Product: CSS
Classification: Unclassified
Component: Animations
unspecified
PC All
: P2 normal
: ---
Assigned To: Dean Jackson
This bug has no owner yet - up for the taking
[hard][postpone]
:
: 15839 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-31 17:26 UTC by Dean Jackson
Modified: 2012-03-29 19:26 UTC (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dean Jackson 2011-10-31 17:26:58 UTC
Add an event fired when an animation is removed before it completes.

As resolved at the 2011 TPAC.
Comment 1 Dean Jackson 2011-10-31 18:19:49 UTC
Open questions - what should be the target if the animation is cancelled because the element was removed? Should it fire on the nearest parent? Should it not fire at all?
Comment 2 Dean Jackson 2011-10-31 19:39:17 UTC
resolution : fire the event on the element, even if it's has been removed.
Comment 3 Sylvain Galineau 2012-03-09 21:42:11 UTC
*** Bug 15839 has been marked as a duplicate of this bug. ***
Comment 4 L. David Baron (Mozilla) 2012-03-29 05:28:56 UTC
The group resolved to postpone this to the next level per minutes at http://lists.w3.org/Archives/Public/www-style/2012Mar/0655.html .  (What does that mean we should do in Bugzilla?)
Comment 5 Simon Fraser 2012-03-29 15:43:48 UTC
We could move to RESOLVED/LATER, or we could request that relevant Target Milestones be added to Bugzilla.
Comment 6 Edward O'Connor 2012-03-29 16:41:37 UTC
FWIW, the HTML editor uses RESOLVED/LATER as Simon suggests.
Comment 7 Sylvain Galineau 2012-03-29 19:26:52 UTC
WG decision: address in Level 4 of the specification.