This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 14178 - <track> WebVTT cue discarded and then used (SIGSEGV)
Summary: <track> WebVTT cue discarded and then used (SIGSEGV)
Status: RESOLVED FIXED
Alias: None
Product: WHATWG
Classification: Unclassified
Component: HTML (show other bugs)
Version: unspecified
Hardware: Other other
: P3 blocker
Target Milestone: Unsorted
Assignee: Ian 'Hixie' Hickson
QA Contact: contributor
URL: http://www.whatwg.org/specs/web-apps/...
Whiteboard:
Keywords:
: 14179 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-16 09:14 UTC by contributor
Modified: 2012-07-18 18:39 UTC (History)
3 users (show)

See Also:


Attachments

Description contributor 2011-09-16 09:14:41 UTC
Specification: http://www.whatwg.org/specs/web-apps/current-work/multipage/the-video-element.html
Multipage: http://www.whatwg.org/C#parsing-0
Complete: http://www.whatwg.org/c#parsing-0

Comment:
WebVTT cue discarded and then used (SIGSEGV)

Posted from: 83.218.67.122 by philipj@opera.com
User agent: Opera/9.80 (X11; Linux x86_64; U; Edition Next; en) Presto/2.9.186 Version/12.00
Comment 1 Philip J├Ągenstedt 2011-09-16 09:17:12 UTC
*** Bug 14179 has been marked as a duplicate of this bug. ***
Comment 2 Philip J├Ągenstedt 2011-09-16 11:45:12 UTC
http://www.whatwg.org/specs/web-apps/current-work/multipage/the-video-element.html#webvtt-parser-algorithm

In step 42 and 44, the cue is discarded and there is a jump to step 51, where cue is used. When implemented naively, this is a segfault.

The solution is to drop "discard cue and" from steps 42 and 44. This means that empty cues will be allowed, which is IMO the sane behavior. (Dropping an entire cue because it wasn't ended with a newline is not.)
Comment 3 Ian 'Hixie' Hickson 2011-09-19 23:14:55 UTC
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are satisfied with this response, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:
   http://dev.w3.org/html5/decision-policy/decision-policy.html

Status: Accepted
Change Description: see diff given below
Rationale: Yeah that didn't make any sense. Empty cues aren't supposed to be discarded. Not sure what I was doing here. Probably forgot to do some fix-ups after some copy-and-paste...
Comment 4 contributor 2011-09-19 23:15:35 UTC
Checked in as WHATWG revision r6556.
Check-in comment: Avoid discarding the last cue in a file if it's empty, or any empty cue that is only terminated with CR and not CRLF. Also, explicitly allow empty metadata cues.
http://html5.org/tools/web-apps-tracker?from=6555&to=6556