This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 11244 - Should we say that a <video> element doesn't plan when moved around in a document rather than removed?
Summary: Should we say that a <video> element doesn't plan when moved around in a docu...
Status: RESOLVED DUPLICATE of bug 11068
Alias: None
Product: HTML WG
Classification: Unclassified
Component: LC1 HTML5 spec (show other bugs)
Version: unspecified
Hardware: Other other
: P3 normal
Target Milestone: ---
Assignee: Ian 'Hixie' Hickson
QA Contact: HTML WG Bugzilla archive list
URL: http://www.whatwg.org/specs/web-apps/...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-05 22:47 UTC by contributor
Modified: 2011-08-04 05:04 UTC (History)
5 users (show)

See Also:


Attachments

Description contributor 2010-11-05 22:47:27 UTC
Specification: http://www.whatwg.org/specs/web-apps/current-work/complete.html
Section: http://www.whatwg.org/specs/web-apps/current-work/#media-playback

Comment:
Should we say that a <video> element doesn't plan when moved around in a
document rather than removed?

Posted from: 216.239.45.4 by ian@hixie.ch
Comment 1 Philip J├Ągenstedt 2010-11-08 08:07:58 UTC
I assume s/plan/pause/. If so, then we pretty much have to change the pausing to a "queue a task" to pause, additionally checking if it's in the document when running that task.

I think it might be useful, but it is more work to implement and I haven't heard anyone actually asking for this, yet.
Comment 2 Ian 'Hixie' Hickson 2010-12-29 08:19:58 UTC
Well we'd probably do it using a synchronous section, not a task, but yeah, it would clearly be more complex. See bug 11068, though.

*** This bug has been marked as a duplicate of bug 11068 ***
Comment 3 Michael[tm] Smith 2011-08-04 05:04:27 UTC
mass-moved component to LC1