This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 11068 - We should not pause() if the element is removed from a document and then reinserted in the same task, since otherwise that could cause stuttering when moving a video from one frame to another, and would break autoplay when used with innerHTML.
Summary: We should not pause() if the element is removed from a document and then rein...
Status: RESOLVED FIXED
Alias: None
Product: HTML WG
Classification: Unclassified
Component: LC1 HTML5 spec (show other bugs)
Version: unspecified
Hardware: Other other
: P3 normal
Target Milestone: ---
Assignee: Ian 'Hixie' Hickson
QA Contact: HTML WG Bugzilla archive list
URL: http://www.whatwg.org/specs/web-apps/...
Whiteboard:
Keywords:
: 11244 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-15 19:33 UTC by contributor
Modified: 2011-08-04 05:06 UTC (History)
8 users (show)

See Also:


Attachments

Description contributor 2010-10-15 19:33:28 UTC
Section: http://www.whatwg.org/specs/web-apps/current-work/#media-playback

Comment:
We should not pause() if the element is removed from a document and then
reinserted in the same task, since otherwise that could cause stuttering when
moving a video from one frame to another, and would break autoplay when used
with innerHTML.

Posted from: 216.239.45.4 by ian@hixie.ch
Comment 1 Philip J├Ągenstedt 2010-10-18 07:42:49 UTC
True, but it's not trivial to implement. Is there a good use-case for moving video between frames without audio stutter to motivate that implementation burden?

Also, I don't understand what would happen with autoplay and innerHTML, can someone clarify?
Comment 2 Simon Pieters 2010-10-18 07:48:51 UTC
innerHTML is specified in terms of first parsing into a separate Document and then moving the nodes.
Comment 3 Ian 'Hixie' Hickson 2010-12-29 08:19:58 UTC
*** Bug 11244 has been marked as a duplicate of this bug. ***
Comment 4 Ian 'Hixie' Hickson 2011-01-21 01:35:33 UTC
Use cases for this just looking at Google apps:

* drag-and-drop of a <video> or something containing a video should not pause the video (e.g. imagine a widget in iGoogle that you can drag to elsewhere on the page).

* popping out a video conference <video> from an in-page chat panel to a separate window (e.g. imagine popping out a video conference happening in an IM window in GMail).

* transitioning a video that is playing in a search results page into a video that seems to be playing in a page dedicated to that video (e.g. imagine a search on YouTube, where you can preview videos on the search page but once you've picked one it dynamically reconstructs the page to be the main play page for the video, using pushState and so on).

Obviously these use cases apply to more than just Google projects, I just didn't want to pick on another company's products.

For autoplay="" and innerHTML, the problem is innerHTML is defined in terms that involve a removal of the <video> node from a Document (a hypothetical one, but that doesn't really matter), and that resets the autoplay functionality.
Comment 5 Ian 'Hixie' Hickson 2011-02-17 00:51:47 UTC
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are satisfied with this response, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:
   http://dev.w3.org/html5/decision-policy/decision-policy.html

Status: Accepted
Change Description: see diff given below
Rationale: Concurred with reporter's comments.
Comment 6 contributor 2011-02-17 00:52:10 UTC
Checked in as WHATWG revision r5899.
Check-in comment: Make it so moving a video around the DOM doesn't pause it. Also make innerHTML work for <video> elements.
http://html5.org/tools/web-apps-tracker?from=5898&to=5899
Comment 7 Michael[tm] Smith 2011-08-04 05:06:58 UTC
mass-moved component to LC1