Bug 9969 - The polyglot publication implies it is normative
The polyglot publication implies it is normative
Status: RESOLVED WONTFIX
Product: HTML WG
Classification: Unclassified
Component: pre-LC1 HTML/XHTML Compat. Authoring Guide (ed: Eliot Graff)
unspecified
All All
: P2 normal
: ---
Assigned To: Eliot Graff
HTML WG Bugzilla archive list
http://dev.w3.org/html5/html-xhtml-au...
:
: 19923 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-21 07:52 UTC by Henri Sivonen
Modified: 2012-11-12 21:54 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Henri Sivonen 2010-06-21 07:52:57 UTC
Polyglot Markup: HTML-Compatible XHTML Documents marks its introduction as non-normative and has "Normative References". This implies that the document is normative.

The publication should be a set of logical conclusions inferred from the HTML5, XML, Namespaces in XML and DOM (and possibly CSS) specs. As such, it logically should be totally void of any normative statements of its own.

Please mark the publication as non-normative and state that it states logical conclusions drawn from the normative matter in other publications.
Comment 1 Lachlan Hunt 2010-07-28 14:53:14 UTC
The risk of having this document published as normative is that it has a serious risk of stating conflicting requirements with regards to the actual requirements defined in the HTML5 and XML family of specifications.

A good example of this is the current drafts incorrect requirement for lowercase attribute values.  Another is the incorrect permission to use alternative XHTML DOCTYPEs, beyond those considered obsolete but permitted in HTML5.  The risk of such mistakes slipping through the cracks, leading to a situation where neither document can claim authority over the other, is just too problematic and should be avoided.

There are other cases claiming normativity is a problem even without a specific conflict, like with the stated requirement for explicit tbody tags, even though the content model of table permits tr as a child without tbody.  The document should instead note the syntactic discrepancy between HTML and XHTML and recommend that authors do include the tbody tags, but without attempting to impose a largely inconsequential normative authoring requirement.
Comment 2 Eliot Graff 2010-12-06 20:58:55 UTC
After lengthy and careful consideration, I am going to resolve this as won't fix for the following reasons.

"Polyglot Markup: HTML-Compatible XHTML Documents" is a normative specification that defines and prescribes behavior for "polyglot markup," as defined within that specification. However, because there are no consequences to user agents, only to authors (not having the same DOM and not creating content that validates as either HTML5 or XML), I have consciously removed any RFC 2119 language, UNLESS it is required by an original normative specification.

Regarding the other issue in comment 1: as many other specifications do, the polyglot spec relies upon some definitions that come from other normative specifications. When and if the references within the polglot spec are in error or mis-quote the original spec, a bug should be logged against the polyglot specification to that extent, and as editor, I will make corrections as quickly as possible.

Thank you for your patience and your input.

Eliot
Comment 3 Eliot Graff 2012-11-12 21:54:35 UTC
*** Bug 19923 has been marked as a duplicate of this bug. ***