This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 9791 - IDBDatabase should (possibly) be renamed to IDBConnection
Summary: IDBDatabase should (possibly) be renamed to IDBConnection
Alias: None
Product: WebAppsWG
Classification: Unclassified
Component: Indexed Database API (show other bugs)
Version: unspecified
Hardware: All All
: P2 normal
Target Milestone: ---
Assignee: Andrei Popescu
QA Contact: public-webapps-bugzilla
Depends on:
Reported: 2010-05-21 16:33 UTC by Jeremy Orlow
Modified: 2010-06-11 10:55 UTC (History)
4 users (show)

See Also:


Description Jeremy Orlow 2010-05-21 16:33:28 UTC
Andrei Popescu proposed a couple naming changes to the interfaces within IndedexDB deep within the "[IndexDB] Proposal for async API changes" thread [1].

One of the proposals was to change IDBDatabase to IDBConnection.  This proposal met with some opposition (unlike the other two) and thus should probably be discussed further and possibly marked as invalid.

The voices are Andrei, Shawn, Jonas, and Jeremy in that order:

> >>> - Some of the interfaces could have names that would more closely
> >>> reflect their roles in the API. For instance, IDBDatabase could be
> >>> renamed to IDBConnection, since in the spec it is described as "a
> >>> connection to the database".
> >>
> >> This sounds good as well.
> >
> > Not really sold on this. I've always hated the "connection"
> > abstraction. With our suggested API IDBDatabase really just holds
> > metadata information about the database, and doesn't need to represent
> > a connection at all.
> Well, if we don't make these proposed changes, then I think it's pretty important
> to rename to connection since the current spec does distinguish between each
> connection.
> With your proposal, this is not currently true, but I think it's hard to say whether
> or not these concepts will creep back in in later versions.  In addition, the entire
> spec is related to databases, so I think naming it a "connection" rather than a
> "database" helps distinguish it from the rest.
> That said, if IndexedDatabase* becomes IDBFactory* then there certainly is a lot
> less confusion already, and this change is less important.