This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 7776 - rename appcache events?
Summary: rename appcache events?
Alias: None
Product: HTML WG
Classification: Unclassified
Component: pre-LC1 HTML5 spec (editor: Ian Hickson) (show other bugs)
Version: unspecified
Hardware: PC Linux
: P2 normal
Target Milestone: ---
Assignee: Ian 'Hixie' Hickson
QA Contact: HTML WG Bugzilla archive list
Keywords: NE
Depends on:
Reported: 2009-09-30 16:24 UTC by Anne
Modified: 2010-12-01 15:30 UTC (History)
6 users (show)

See Also:


Description Anne 2009-09-30 16:24:02 UTC
The appcache events are not consistent in style. Is is still feasible to introduce changes here and make them more consistent?

* obsolete -> obsoleted
* updateready -> updated
* noupdate -> notupdated

This would make these events consistent with cached.

progress could be renamed to progressing to be more consistent with similar events though I think it should get a different name altogether as suggested in another bug.
Comment 1 Anne 2009-09-30 16:24:21 UTC
Adding NE keyword so other implementors see this.
Comment 2 Maciej Stachowiak 2009-10-02 06:38:28 UTC
We have implemented these in WebKit. I do not know if they are used. There are definitely mobile sites using the app cache, but I don't have any quantitative data.

The suggested new names don't seem sufficiently better to be worth the change. It seems to be standard for DOM events to be named in the present tense instead of the past tense - "click" not "clicked", "load" not "loaded". If anything, "cached" is the odd man out.
Comment 3 Ian 'Hixie' Hickson 2009-10-18 11:00:10 UTC
I don't feel comfortable changing these now. Please feel free to escalate this if you disagree.