This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 30025 - [F+O3.1] array:join() - misleading name
Summary: [F+O3.1] array:join() - misleading name
Alias: None
Product: XPath / XQuery / XSLT
Classification: Unclassified
Component: Functions and Operators 3.1 (show other bugs)
Version: Candidate Recommendation
Hardware: PC All
: P2 normal
Target Milestone: ---
Assignee: Michael Kay
QA Contact: Mailing list for public feedback on specs from XSL and XML Query WGs
Depends on:
Reported: 2016-11-30 17:18 UTC by Michael Kay
Modified: 2016-12-16 19:55 UTC (History)
1 user (show)

See Also:


Description Michael Kay 2016-11-30 17:18:51 UTC
Comment from Thomas Fischer on public-qt-comments:

The documentation for array:join says:
    Concatenates the contents of several arrays
and "concat" is a common term for such functionality for arrays, whereas "join" is common to join the elements of an array into a string, separated by a specified separator.

Therefore I would propose:

  array:join($array as array(*)) as xs:string
  array:join($array as array(*), $separator as xs:string) as xs:string

  array:concat($arrays as array(*)*) as array(*)
Comment 1 Michael Kay 2016-11-30 17:19:57 UTC
Provisional personal response:

Thanks for the feedback but I fear it is too late now to make cosmetic changes like this; the cost of making the change exceeds any benefit.
Comment 2 Josh Spiegel 2016-11-30 17:28:07 UTC
Yes, thank you for the feedback.  I might have also preferred "concat" but I think "join" is OK and I agree with Mike that the cost of making this change is not justified at this point.
Comment 3 Michael Kay 2016-12-06 16:21:34 UTC
The WG decided to close this as "works for me" on the basis that it's too late to be making such changes.