This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 28264 - [webvtt] 4.3.2 very few character escapes [I18N-ISSUE-430]
Summary: [webvtt] 4.3.2 very few character escapes [I18N-ISSUE-430]
Status: RESOLVED DUPLICATE of bug 23867
Alias: None
Product: TextTracks CG
Classification: Unclassified
Component: WebVTT (show other bugs)
Version: unspecified
Hardware: PC All
: P2 normal
Target Milestone: ---
Assignee: This bug has no owner yet - up for the taking
QA Contact: Web Media Text Tracks CG
URL:
Whiteboard: widereview
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-22 00:16 UTC by Silvia Pfeiffer
Modified: 2017-08-09 11:42 UTC (History)
4 users (show)

See Also:
silviapfeiffer1: needinfo? (addison)


Attachments

Description Silvia Pfeiffer 2015-03-22 00:16:15 UTC
Feedback by Addison Phillips from W3C I18N group:
http://lists.w3.org/Archives/Public/public-tt/2015Mar/0063.html

I18N comment: https://www.w3.org/International/track/issues/430

4.3.2 WebVTT cue text
http://www.w3.org/TR/webvtt1/#dfn-webvtt-cue-amp-escape

There are escape sequences defined for six Unicode characters (&, <, >, LRM, RLM, and NBSP), but not a general purpose escape mechanism for characters. It's generally recommended that character escapes be provided so that difficult to enter or edit sequences can be introduced using a plain text editor. E.g. something like HTML's &#x123AB; syntax.

Escape sequences are particularly useful for invisible or ambiguous Unicode characters, including zero-width spaces, soft-hyphens, various bidi controls, mongolian vowel separators, etc.

For advice on use of escapes in markup, but that is mostly generalisable to other formats, see http://www.w3.org/International/questions/qa-escapes
Comment 1 Philip J├Ągenstedt 2015-03-23 03:40:51 UTC
Thanks for the new links. There's an older issue for this which I'm making this a dupe of: bug 23867.

*** This bug has been marked as a duplicate of bug 23867 ***
Comment 2 Silvia Pfeiffer 2017-08-09 11:42:23 UTC
Addison,
Would you mind adding a note to https://github.com/w3c/webvtt/pull/253 whether you're ok with it resolving this bug?