This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 27740 - Suggest changing interface name 'MediaKeyStatuses' to 'MediaKeyStatusMap'
Summary: Suggest changing interface name 'MediaKeyStatuses' to 'MediaKeyStatusMap'
Alias: None
Product: HTML WG
Classification: Unclassified
Component: Encrypted Media Extensions (show other bugs)
Version: unspecified
Hardware: All All
: P2 normal
Target Milestone: ---
Assignee: David Dorwin
QA Contact: HTML WG Bugzilla archive list
Whiteboard: API_Compatibility
Depends on:
Blocks: 27739
  Show dependency treegraph
Reported: 2015-01-03 23:44 UTC by Glenn Adams
Modified: 2015-01-15 01:35 UTC (History)
3 users (show)

See Also:


Description Glenn Adams 2015-01-03 23:44:35 UTC
Since MediaKeyStatuses is nothing more than a maplike<>, I suggest changing the name to MediaKeyStatusMap. The term 'status' is often used as a mass noun, in which case status is also the plural. Since there is also a MediaKeyStatus interface, I see why this wasn't an option, but 'statuses' just sounds odd to me.
Comment 1 David Dorwin 2015-01-07 21:12:35 UTC
Note that the name of the attribute that uses this type is "keyStatuses". Would this change too?
Comment 2 David Dorwin 2015-01-13 21:46:45 UTC
As discussed in the telecon today, we'll change the name of the type. Note, that this is also consistent with MIDIInputMap [1].

Other interesting things from the Web MIDI spec:
1. The map key is DOMString "id", and the value is MIDIInput "port" [1]. Thus, the "MIDI input map", is a map of an ID to a MIDIInput.
2. The attribute that uses MIDIInputMap is named "inputs" and has the description "The MIDI input ports available to the system. [2]"

Applying these to EME:
#1 - MediaKeyStatusMap is a map of an ID to a MediaKeyStatus.
#2 - keyStatuses is the shortened plural name of the type of value (MediaKeyStatus > keyStatuses as MIDIInput > inputs).

In summary, the type will change to MediaKeyStatusMap and we will keep the attribute name "keyStatuses".

Comment 4 Glenn Adams 2015-01-15 01:35:03 UTC