This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 24117 - "keys" and "setMediaKeys()" should be named consistently
Summary: "keys" and "setMediaKeys()" should be named consistently
Alias: None
Product: HTML WG
Classification: Unclassified
Component: Encrypted Media Extensions (show other bugs)
Version: unspecified
Hardware: All All
: P3 normal
Target Milestone: ---
Assignee: Adrian Bateman [MSFT]
QA Contact: HTML WG Bugzilla archive list
Depends on:
Reported: 2013-12-16 20:08 UTC by David Dorwin
Modified: 2014-01-07 17:06 UTC (History)
2 users (show)

See Also:


Description David Dorwin 2013-12-16 20:08:46 UTC
It's odd that we have "Media" and thus the full type (MediaKeys) in the setting function ("setMediaKeys()") but not in the attribute ("keys"). They both operate on the same type and reference the same underlying object.

We should either rename the attribute to "mediaKeys" or rename the method to "setKeys()"

Using the full type name is nice, but "Media" is also redundant since these are members of HTMLMediaElement.
Comment 1 Adrian Bateman [MSFT] 2014-01-07 17:06:17 UTC
Discussed in telcon today. Proposal was to rename attribute to mediaKeys. Change is here: