This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 23874 - [WebVTT] Should there be support for <rp>?
Summary: [WebVTT] Should there be support for <rp>?
Status: RESOLVED DUPLICATE of bug 28265
Alias: None
Product: TextTracks CG
Classification: Unclassified
Component: WebVTT (show other bugs)
Version: unspecified
Hardware: PC All
: P2 normal
Target Milestone: ---
Assignee: Silvia Pfeiffer
QA Contact: This bug has no owner yet - up for the taking
URL:
Whiteboard: v2
Keywords:
Depends on:
Blocks: 28265
  Show dependency treegraph
 
Reported: 2013-11-20 13:00 UTC by Fredrik S
Modified: 2015-09-30 19:40 UTC (History)
5 users (show)

See Also:


Attachments

Description Fredrik S 2013-11-20 13:00:34 UTC
Prompted by http://crbug.com/150927 .

Should <rp> tags be allowed under <ruby> tags? Currently they will be treated as "unrecognized", and hence end being dropped. As can be seen in the screenshot in the bug referenced above, this can give rise to odd-looking rendering even in UAs that support Ruby. (The rendering in non-supporting UAs will get pretty longwinded though...)
Comment 1 Ralph Giles 2013-11-21 01:15:43 UTC
It certainly looks bad. OTOH the WebVTT generator could strip this.

How popular is <rp> with Japanese subtitlers?
Comment 2 Fredrik S 2013-11-21 09:04:49 UTC
(In reply to Ralph Giles from comment #1)
> It certainly looks bad. OTOH the WebVTT generator could strip this.

I agree, and that would probably be my personal preference (i.e. "no change").
 
> How popular is <rp> with Japanese subtitlers?

No idea. AFAICT, the referenced example is constructed.
Comment 3 Silvia Pfeiffer 2013-11-21 17:25:56 UTC
I'm planning on aligning the WebVTT spec with the HTML spec once http://darobin.github.io/html-ruby/ has been sorted out. For now, I don't think we have any content that would be broken.
Comment 4 Ralph Giles 2013-11-21 21:09:17 UTC
Just to clarify, you plan to adopt the full set of ruby tags from the HTML spec, including <rp>, <rb> etc?
Comment 5 Silvia Pfeiffer 2013-11-21 22:47:29 UTC
(In reply to Ralph Giles from comment #4)
> Just to clarify, you plan to adopt the full set of ruby tags from the HTML
> spec, including <rp>, <rb> etc?

I don't have enough knowledge myself about ruby-like needs, but Robin has done an enormous amount of research. It seems his proposal satisfies all the use cases. So, yes, I thought I would just accept all of the elements he is proposing.

Are you against that?
Comment 6 Philip J├Ągenstedt 2014-01-29 17:50:29 UTC
The situation is:

WebVTT has <ruby> and <rt>

http://whatwg.org/html has <ruby>, <rt> and <rp>

http://darobin.github.io/html-ruby/ has <ruby>, <rb>, <rt>, <rtc> and <rp>

I do not think we should align with darobin's spec until it has been implemented for HTML in some browser with positive results.

As for <rp>, the HTML spec says that "The rp element can be used to provide parentheses or other content around a ruby text component of a ruby annotation, to be shown by user agents that don't support ruby annotations."

This seems somewhat odd to add for WebVTT, can't browsers that implement WebVTT also just implement the ruby bits?

All in all, I would suggest no change for v1, unless that change can be shown to fix some cases that are common in subtitles.

Silvia, do you support moving this to v2?
Comment 7 Ralph Giles 2014-01-29 18:35:54 UTC
(In reply to Philip J├Ągenstedt from comment #6)

> As for <rp>, the HTML spec says that "The rp element can be used to provide
> parentheses or other content around a ruby text component of a ruby
> annotation, to be shown by user agents that don't support ruby annotations."

That was my thought as well. The counter-argument is that it's nice to copy/paste ruby markup in html, so supporting the same tag set is nicer for authors.

We looked and didn't find any wild examples of <rp> in subtitles.

> Silvia, do you support moving this to v2?

FWIW I think postponing is a fine idea. I don't expect we'll have resources to implement this in Firefox in the near term.
Comment 8 Silvia Pfeiffer 2014-01-30 22:53:11 UTC
Moving to v2. I too wanted to wait until browsers implement the <ruby> related tags.
Comment 9 Silvia Pfeiffer 2015-09-30 19:40:16 UTC
Closing as a duplicate of Bug 28265. If we come across a need for <rp>, we can always re-open this.

*** This bug has been marked as a duplicate of bug 28265 ***