Bugzilla – Bug 22084
Consistent key names in D3E spec
Last modified: 2013-07-31 13:51:42 UTC
"Scroll" should be named "ScrollLock" since it's a locking key.
Arrow keys should begin with 'Arrow' prefix to make it more explicit and to group them together. "Down" -> "ArrowDown", ...
'Del' should be 'Delete'. Just like 'Insert' is not 'Ins'.
We should consistently use the 'Toggle' suffix for keys that toggle state.
The 'Apps' key (media key from OCAP) is confusable with the (more common) Windows VK_APPS/VK_CONTEXT_MENU key, which is missing from this list.
Yep. Agree with ScrollLock.
Agree with the Arrow prefix.
I like the consistency for "Delete" (not Del) as it's spelled out on my keyboard like that.
I don't have a preference on the 'Toggle' (not sure it's too bad).
'Apps' key in IE9+ is the right-click context menu key. Perhaps 'AppsMenu'.
(In reply to comment #1)
> 'Apps' key in IE9+ is the right-click context menu key. Perhaps 'AppsMenu'.
AppsMenu sounds like a menu for application global. Why don't you use "ContextMenu"? It's more famous name.
Fixed in current ED.
ArrowDown, ArrowUp, ArrowLeft, ArrowRight