Bug 21225 - [Imports]: Component interface is not necessary
Summary: [Imports]: Component interface is not necessary
Status: RESOLVED FIXED
Alias: None
Product: WebAppsWG
Classification: Unclassified
Component: HISTORICAL - Component Model (show other bugs)
Version: unspecified
Hardware: PC All
: P2 normal
Target Milestone: ---
Assignee: Dimitri Glazkov
QA Contact: public-webapps-bugzilla
URL:
Whiteboard:
Keywords:
: 21979 (view as bug list)
Depends on:
Blocks: 20683
  Show dependency treegraph
 
Reported: 2013-03-08 18:01 UTC by Dimitri Glazkov
Modified: 2013-05-14 22:45 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitri Glazkov 2013-03-08 18:01:38 UTC
"The Component interface represents a component in a master document:"

Let LinkComponent hold Document directly.
Comment 1 Anne 2013-05-08 22:37:07 UTC
*** Bug 21979 has been marked as a duplicate of this bug. ***
Comment 2 Anne 2013-05-08 22:37:56 UTC
I suggest:

partial interface HTMLLinkElement {
  readonly attribute Document? importContent;
}
Comment 3 Anne 2013-05-08 22:42:55 UTC
Prolly DocumentFragment per bug 21255.
Comment 4 Dimitri Glazkov 2013-05-14 22:45:24 UTC
https://dvcs.w3.org/hg/webcomponents/rev/7e7d40858f0b