Bug 20984 - Does header belong to its nearest ancestor sectioning content/root element?
Summary: Does header belong to its nearest ancestor sectioning content/root element?
Status: RESOLVED DUPLICATE of bug 20550
Alias: None
Product: HTML WG
Classification: Unclassified
Component: HTML5 spec (show other bugs)
Version: unspecified
Hardware: All All
: P2 normal
Target Milestone: ---
Assignee: This bug has no owner yet - up for the taking
QA Contact: HTML WG Bugzilla archive list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-12 21:58 UTC by Stefan Götz
Modified: 2013-03-17 17:42 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Götz 2013-02-12 21:58:15 UTC
The definition of the footer element [1] makes clear that it belongs to "its nearest ancestor sectioning content or sectioning root element".

For the header element [2] such a clarification is missing:

> The header element represents a group of introductory or navigational aids.

However, in the Note it refers to sections:

> A header element is intended to usually contain the section's heading […]

Is this difference intended?
I thought that footer and header would differ only in what *kind* of content they should be used for.

[1] http://www.w3.org/html/wg/drafts/html/master/sections.html#the-footer-element
[2] http://www.w3.org/html/wg/drafts/html/master/sections.html#the-header-element
Comment 1 steve faulkner 2013-03-17 17:42:54 UTC
Refer to resolution of https://www.w3.org/Bugs/Public/show_bug.cgi?id=20550

*** This bug has been marked as a duplicate of bug 20550 ***