Bug 20978 - Just an API for encouraging the use of proprietary plugins
Just an API for encouraging the use of proprietary plugins
Status: RESOLVED WONTFIX
Product: HTML WG
Classification: Unclassified
Component: Encrypted Media Extensions
unspecified
PC Linux
: P2 blocker
: ---
Assigned To: Adrian Bateman [MSFT]
HTML WG Bugzilla archive list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-12 15:29 UTC by Andreas Kuckartz
Modified: 2013-02-26 17:07 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Kuckartz 2013-02-12 15:29:59 UTC
This is just an API for encouraging the use
of proprietary plugins ("CDMs").

(Using a formulation by Ian Hixie)
Comment 1 Fred Andrews 2013-02-12 23:21:50 UTC
This seems to be related to Bug 20963 (EME is technically incomplete).  Specifying the CDM would likely allow the API to be removed or reworked so as not to encourage the use of proprietary plugins.
Comment 2 Adrian Bateman [MSFT] 2013-02-26 17:07:22 UTC
Discussed on the telcon:
http://www.w3.org/2013/02/26-html-media-minutes.html

CDMs by design are out of scope for this document. If someone wants to design a different solution to protected content that doesn't push CDMs out of scope they are welcome to. The EME spec is not designed to prevent "plug-in CDMs" but will likely constrain there scope more than generic plug-ins.