Bug 20962 - The EMEs CDM depends on patented technology.
The EMEs CDM depends on patented technology.
Status: RESOLVED WONTFIX
Product: HTML WG
Classification: Unclassified
Component: Encrypted Media Extensions
unspecified
PC Windows NT
: P2 normal
: ---
Assigned To: Adrian Bateman [MSFT]
HTML WG Bugzilla archive list
:
Depends on: 21104
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-12 02:26 UTC by Fred Andrews
Modified: 2013-02-26 23:38 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fred Andrews 2013-02-12 02:26:16 UTC
The CDM will most likely be patented technology and no path is offered for this to be royalty free and thus is not compatible with the W3C process.
Comment 1 Adrian Bateman [MSFT] 2013-02-12 13:37:51 UTC
The spec includes the following text:

"This document was produced by a group operating under the 5 February 2004 W3C Patent Policy. W3C maintains a public list of any patent disclosures made in connection with the deliverables of the group; that page also includes instructions for disclosing a patent. An individual who has actual knowledge of a patent which the individual believes contains Essential Claim(s) must disclose the information in accordance with section 6 of the W3C Patent Policy."
Comment 2 Fred Andrews 2013-02-12 20:10:59 UTC
The EME appears to try to separate itself from the CDM and it is not clear that the CDM would fall under the W3C terms.  Please include the specification of the CDM so that participants can agree that it is royalty free.  Participants can not agree to vapor.
Comment 3 Fred Andrews 2013-02-20 15:59:08 UTC
Clarified the bug description.
Comment 4 Adrian Bateman [MSFT] 2013-02-26 15:59:11 UTC
Resolved WONTFIX as discussed in telcon:
http://www.w3.org/2013/02/19-html-media-minutes.html

CDMs by design are out of scope for this document. If someone wants to design a different solution to protected content that doesn't push CDMs out of scope they are welcome to.
Comment 5 Fred Andrews 2013-02-26 23:38:24 UTC
(In reply to comment #4)
> Resolved WONTFIX as discussed in telcon:
> http://www.w3.org/2013/02/19-html-media-minutes.html
> 
> CDMs by design are out of scope for this document. If someone wants to
> design a different solution to protected content that doesn't push CDMs out
> of scope they are welcome to.

The EME specification already constrains the CDM, and people
competent in this area would know that the main use case for
the EME specification may well require the use of patented
technology.  The refusal to address this bug raises a concern
about the competence of task force or that they are acting
in good faith.