Bug 20959 - EME does not prevent a per-user specific CDM.
Summary: EME does not prevent a per-user specific CDM.
Status: RESOLVED DUPLICATE of bug 20944
Alias: None
Product: HTML WG
Classification: Unclassified
Component: Encrypted Media Extensions (show other bugs)
Version: unspecified
Hardware: PC Windows NT
: P2 normal
Target Milestone: ---
Assignee: Adrian Bateman [MSFT]
QA Contact: HTML WG Bugzilla archive list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-12 02:16 UTC by Fred Andrews
Modified: 2013-02-12 13:57 UTC (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fred Andrews 2013-02-12 02:16:57 UTC
A specific CDM may be issued to users that discriminates against users.
Comment 1 Mark Watson 2013-02-12 02:28:37 UTC
(In reply to comment #0)
> A specific CDM may be issued to users that discriminates against users.

I'm not sure I understand the issue.

It is certainly the case that a CDM may be individualized in some way. Such individualization should not work when the browser is in any kind of 'anonymous browsing' mode, even if that meant the whole CDM was inoperable in that mode.
Comment 2 Fred Andrews 2013-02-12 12:05:18 UTC
This bug is related to Bug 20944 (EME should do more to encourage/ensure CDM-level interop) which discusses UA specific CDMs.

A CDM specific to each user/device may not be a standard at all and may not be able to pass through the W3C review processes.  This bug may be related to Bug 20963 (EME is technically incomplete).

Bug 20965 (EME results in a loss of control over security and privacy) is also related to the privacy issues.
Comment 3 Adrian Bateman [MSFT] 2013-02-12 13:57:31 UTC
This appears to be a duplicate of the 3 bugs referenced. Marking dup of 20944.

*** This bug has been marked as a duplicate of bug 20944 ***