Bug 20865 - Redirect URLs with trailing slash
Summary: Redirect URLs with trailing slash
Status: RESOLVED DUPLICATE of bug 20290
Alias: None
Product: webplatform.org
Classification: Unclassified
Component: infrastructure (show other bugs)
Version: unspecified
Hardware: PC All
: P2 normal
Target Milestone: ---
Assignee: Ryan Lane
QA Contact: public-webplatform-bugs list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-04 15:03 UTC by Doug Schepers
Modified: 2013-02-04 15:16 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Doug Schepers 2013-02-04 15:03:37 UTC
URLs with a trailing slash are seen as separate page from their non-slash equivalents. Trailing slashes are usually the result of a typo or someone manually editing the URL (for example, to get to a parent page).

These should be the same resource:
http://docs.webplatform.org/wiki/css/properties
http://docs.webplatform.org/wiki/css/properties/

Apparently, the proper fix is to do this in Apache:
 RedirectMatch permanent ^/wiki/(.*)/$ /wiki/$1
Comment 1 Jonathan Garbee 2013-02-04 15:16:11 UTC

*** This bug has been marked as a duplicate of bug 20290 ***