Bug 20736 - [XQ30] Namespace axis
Summary: [XQ30] Namespace axis
Status: RESOLVED FIXED
Alias: None
Product: XPath / XQuery / XSLT
Classification: Unclassified
Component: XQuery 3.0 (show other bugs)
Version: Candidate Recommendation
Hardware: PC Windows NT
: P2 normal
Target Milestone: ---
Assignee: Jonathan Robie
QA Contact: Mailing list for public feedback on specs from XSL and XML Query WGs
URL: http://www.w3.org/TR/2013/CR-xquery-3...
Whiteboard:
Keywords:
: 20738 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-22 17:11 UTC by Tim Mills
Modified: 2013-01-30 20:54 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Mills 2013-01-22 17:11:21 UTC
In 3.3.5 Abbreviated Syntax we find:

"If the axis name is omitted from an axis step, the default axis is child, with two exceptions: if the axis step contains an AttributeTest or SchemaAttributeTest then the default axis is attribute; if the axis step contains namespace-node() then the default axis is namespace.

Note:

In an implementation that does not support the namespace axis, an attempt to access it always raises an error. Thus, an XQuery implementation will always raise an error in this case, since XQuery does not support the namespace axis. The namespace axis is deprecated as of XPath 2.0, but required in some languages that use XPath, including XSLT."

What is the error code in this case?
Comment 1 Tim Mills 2013-01-26 06:30:59 UTC
As an aside, I'd like the namespace axis to be allowed in XQuery 3.0.
Comment 2 Jonathan Robie 2013-01-29 17:40:21 UTC
The Working Group agrees to resolve this together with 20738:

If the axis name is omitted from an axis step, the default axis is child, with two exceptions: if the axis step is an AttributeTest or SchemaAttributeTest then the default axis is attribute; if the axis step is a NamespaceNodeTest then a static error is raised [err:XQSTXXXX].
Comment 3 Michael Kay 2013-01-29 17:59:15 UTC
Minor correction, it's not the axis step that is a AttributeTest etc, it is the NodeTest (part of the axis step).
Comment 4 Jonathan Robie 2013-01-30 20:54:57 UTC
*** Bug 20738 has been marked as a duplicate of this bug. ***