Bug 20705 - [QT3TS] XML Edition tests
[QT3TS] XML Edition tests
Status: CLOSED FIXED
Product: XPath / XQuery / XSLT
Classification: Unclassified
Component: XQuery 3 & XPath 3 Test Suite
Working drafts
PC Windows NT
: P2 normal
: ---
Assigned To: O'Neil Delpratt
Mailing list for public feedback on specs from XSL and XML Query WGs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-18 10:49 UTC by Tim Mills
Modified: 2013-03-21 10:48 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Mills 2013-01-18 10:49:14 UTC
Tests using XML 1.1 shouldn't use assert-xml, since canonicalization is only defined for XML 1.0.

Tests checking for handling of XML 1.0 4th vs. 5th edition should also avoid assert-xml, since this can cause problems in the test driver.
Comment 1 Tim Mills 2013-03-14 13:29:28 UTC
(In reply to comment #0)
> Tests checking for handling of XML 1.0 4th vs. 5th edition should also avoid
> assert-xml, since this can cause problems in the test driver.

I have taken the liberty of adding additional assertions to tests XML10-4ed-Excluded-char-1-new and XML11-1ed-Included-char-1-new.
Comment 2 O'Neil Delpratt 2013-03-20 11:45:19 UTC
I confirm bug has been fixed
Comment 3 Tim Mills 2013-03-21 10:48:41 UTC
Great.  Closing...