Bug 20676 - [XT3TS] regex-syntax-0987
[XT3TS] regex-syntax-0987
Status: RESOLVED FIXED
Product: XPath / XQuery / XSLT
Classification: Unclassified
Component: XSLT 3.0 Test Suite
Working drafts
All All
: P2 normal
: ---
Assigned To: Michael Kay
Mailing list for public feedback on specs from XSL and XML Query WGs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-15 18:08 UTC by Andriy Kvasntysya
Modified: 2014-05-23 16:19 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andriy Kvasntysya 2013-01-15 18:08:38 UTC
This test checks regular expression \c against lot of characters. The issue is with the only character in nonmatch section, U+0346 COMBINING BRIDGE ABOVE.

According to http://www.w3.org/TR/xmlschema11-2/#cces-mce 

\c the set of name characters, those ·matched· by NameChar

And NameChar is defined as

[4a] NameChar ::= NameStartChar | "-" | "." | [0-9] | #xB7 | [#x0300-#x036F] | [#x203F-#x2040]

in http://www.w3.org/TR/xml11/#NT-NameChar. This implies that U+0346 that belongs to range #x0300-#x036F is valid name character and shall match regular expression \c.
Comment 1 Andriy Kvasntysya 2013-01-15 18:15:22 UTC
p.s. This issue is probably related to the fact that NameChar production was changed in 05 February 2008 edition of XML specification. In elder version it includes following production 
http://www.w3.org/TR/2006/REC-xml-20060816/#NT-CombiningChar
that doesn't contain mentioned character, so it was valid at that time.
Comment 2 Michael Kay 2013-01-15 22:01:00 UTC
Yes, I agree. The test is based on the old (pre XML 1.0e4) definitions of name characters. We allow implementations to use either the old or the new definitions; we should either add appropriate dependencies to the tests, or stick to characters that work with both.

The two tests -0986 and -0987 are in any case very unwieldy. I normally don't run them because they take too long, and they are very difficult to read and edit because of the long line length. They need redesigning.
Comment 3 Abel Braaksma 2013-02-15 11:16:20 UTC
We've decided to refactor the test and add dependency checks similar or equal to the QT3 model for support of different XML REC editions.
Comment 4 Abel Braaksma 2014-05-23 16:19:09 UTC
Instead of splitting this unwieldy test in multiple tests and adding dependencies on XML versions solely for one characters seems too far fetched.

I've gone forward and removed the offending character. See Rev#443, 2014-05-23. Bug resolved as fixed.