Bug 20604 - [Shadow]: Event's relatedTarget must be pre-computed before event dispatch
Summary: [Shadow]: Event's relatedTarget must be pre-computed before event dispatch
Status: RESOLVED FIXED
Alias: None
Product: WebAppsWG
Classification: Unclassified
Component: HISTORICAL - Component Model (show other bugs)
Version: unspecified
Hardware: PC All
: P2 normal
Target Milestone: ---
Assignee: Hayato Ito
QA Contact: public-webapps-bugzilla
URL:
Whiteboard:
Keywords:
: 20615 (view as bug list)
Depends on:
Blocks: 22716
  Show dependency treegraph
 
Reported: 2013-01-08 17:28 UTC by Dimitri Glazkov
Modified: 2014-05-29 08:03 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitri Glazkov 2013-01-08 17:28:28 UTC
"The MouseEvent relatedTarget attribute must return the adjusted related target"

We need to compute related target ahead of time, since DOM operations in event listeners could affect the DOM structure.
Comment 1 Dimitri Glazkov 2013-07-17 20:37:38 UTC
*** Bug 20615 has been marked as a duplicate of this bug. ***
Comment 2 Hayato Ito 2014-05-29 08:03:17 UTC
Made it clear at https://github.com/w3c/webcomponents/commit/fc19892ff6bf099323447f6a29808630ca66c348

Let me close.