Bug 20602 - [QT3TS] fn-resolve-uri-32
[QT3TS] fn-resolve-uri-32
Status: CLOSED FIXED
Product: XPath / XQuery / XSLT
Classification: Unclassified
Component: XQuery 3 & XPath 3 Test Suite
Working drafts
PC Windows NT
: P2 normal
: ---
Assigned To: O'Neil Delpratt
Mailing list for public feedback on specs from XSL and XML Query WGs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-08 16:29 UTC by Tim Mills
Modified: 2013-01-10 10:31 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Mills 2013-01-08 16:29:08 UTC
I believe that 

  <assert-string-value>http://www.example.com/this%20doc.html</assert-string-value>

may also be a possible expected result.
Comment 1 Michael Kay 2013-01-08 18:54:57 UTC
OK. The LEIRI spec says spaces SHOULD NOT be %-encoded, but it doesn't say MUST NOT, so I will allow this result.
Comment 2 Tim Mills 2013-01-08 21:45:57 UTC
Thanks.  Are you basing you response on the text

"Conversion from a LEIRI to an IRI or a URI must be performed only when absolutely necessary and as late as possible in a processing chain. In particular, neither the process of converting a relative LEIRI to an absolute one nor the process of passing a LEIRI to a process or software component responsible for dereferencing it should trigger percent-encoding."

or something else?
Comment 3 Michael Kay 2013-01-08 22:26:28 UTC
Yes, that's the text I was relying on. Given that we are dealing with a relative LEIRI that is not an IRI, the advice

the process of converting a relative LEIRI to an absolute one ... should [not] trigger percent-encoding

seems to cover this situation rather precisely.
Comment 4 Tim Mills 2013-01-10 10:31:00 UTC
Confirmed fixed.  Thanks.

I'd argue that because resolve-uri returns a new URI, the implementation is at liberty to return a URI, IRI or LEIRI regardless of the input.  Perhaps this could be clarified in the specification?  It's not _just_ converting from a relative to an absolute URI.