Bug 20562 - Objects supporting indexed properties
Objects supporting indexed properties
Status: RESOLVED DUPLICATE of bug 20561
Product: WebAppsWG
Classification: Unclassified
Component: WebIDL
unspecified
PC All
: P2 normal
: ---
Assigned To: Cameron McCormack
public-webapps-bugzilla
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-04 02:09 UTC by Marcos Caceres
Modified: 2013-01-04 02:10 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcos Caceres 2013-01-04 02:09:41 UTC
At: http://dev.w3.org/2006/webapi/WebIDL/#es-sequence

The spec says "Let length be one greater than V’s maximum indexed property index, if V is a platform object that supports indexed properties or the result of calling [[Get]] on V with property name “length” otherwise"

Is there any object that is a platform object that supports indexed properties but does not have a length property? Is there a use case for not mandating that such objects have a length property?
Comment 1 Marcos Caceres 2013-01-04 02:10:28 UTC
https://www.w3.org/Bugs/Public/show_bug.cgi?id=

*** This bug has been marked as a duplicate of bug 20561 ***